summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2021-01-29 23:12:07 -0600
committerJoonas Niilola <juippis@gentoo.org>2021-02-11 10:56:03 +0200
commit3dc0c762d3c36d47e4261bbc184291f69085c14b (patch)
tree97746428fec1fd815bb1f0aef64c1f674f9796ab /net-misc/apt-cacher-ng
parentnet-misc/apt-cacher-ng: bump to 3.5_p3 (diff)
downloadgentoo-3dc0c762d3c36d47e4261bbc184291f69085c14b.tar.gz
gentoo-3dc0c762d3c36d47e4261bbc184291f69085c14b.tar.bz2
gentoo-3dc0c762d3c36d47e4261bbc184291f69085c14b.zip
net-misc/apt-cacher-ng: update live
Also make the version 9999 rather than 9999999, this is how the live version is typically denoted across the tree. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/apt-cacher-ng')
-rw-r--r--net-misc/apt-cacher-ng/apt-cacher-ng-9999.ebuild95
-rw-r--r--net-misc/apt-cacher-ng/apt-cacher-ng-9999999.ebuild121
2 files changed, 95 insertions, 121 deletions
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-9999.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-9999.ebuild
new file mode 100644
index 000000000000..eeecc4fa1d9c
--- /dev/null
+++ b/net-misc/apt-cacher-ng/apt-cacher-ng-9999.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake git-r3
+
+DESCRIPTION="Yet another caching HTTP proxy for Debian/Ubuntu software packages"
+HOMEPAGE="https://www.unix-ag.uni-kl.de/~bloch/acng/
+ https://packages.qa.debian.org/a/apt-cacher-ng.html"
+EGIT_REPO_URI="https://salsa.debian.org/blade/apt-cacher-ng.git"
+EGIT_BRANCH="upstream/sid"
+
+LICENSE="BSD-4 ZLIB public-domain"
+SLOT="0"
+IUSE="doc fuse tcpd"
+
+DEPEND="acct-user/apt-cacher-ng
+ acct-group/apt-cacher-ng
+ app-arch/bzip2
+ dev-libs/libevent:=
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse:0 )
+ tcpd? ( sys-apps/tcp-wrappers )"
+BDEPEND="virtual/pkgconfig"
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.3.1-flags.patch"
+ "${FILESDIR}/${PN}-3.5-perl-syntax.patch"
+)
+
+S="${WORKDIR}/${P/_*}"
+
+src_prepare() {
+ # Fixup systemd/CMakeLists.txt cmake version requirement
+ sed -ie "s/2.6/3.1/" systemd/CMakeLists.txt || die
+
+ # Make sure we install everything the same way it used to be after
+ # switching from mostly custom src_install to relying on build system
+ # installation
+ sed -ie "/install/s/LIBDIR/CFGDIR/" conf/CMakeLists.txt || die
+ sed -ie '/install.*acng\.conf/s/)$/ RENAME '"${PN}"'.conf)/' conf/CMakeLists.txt || die
+ sed -ie '/file/s/)$/ "*hooks" "backends_debian")/' conf/CMakeLists.txt || die
+ sed -ie "/INSTALL.*acngtool/s/LIBDIR/CMAKE_INSTALL_SBINDIR/" source/CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DHAVE_FUSE_25=$(usex fuse)"
+ "-DHAVE_LIBWRAP=$(usex tcpd)"
+ # Unconditionally install systemd service file
+ "-DSDINSTALL=1"
+ )
+
+ if tc-ld-is-gold; then
+ mycmakeargs+=( "-DUSE_GOLD=yes" )
+ else
+ mycmakeargs+=( "-DUSE_GOLD=no" )
+ fi
+
+ cmake_src_configure
+
+ sed -ie '/LogDir/s|/var/tmp|/var/log/'"${PN}"'|g' "${BUILD_DIR}"/conf/acng.conf || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}/initd-r3" "${PN}"
+ newconfd "${FILESDIR}/confd-r2" "${PN}"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotate" "${PN}"
+
+ insinto /etc/cron.daily
+ newins "${FILESDIR}/cron.daily" "${PN}"
+
+ # USE=fuse installs acngfs, don't install manpage without the bin
+ if use !fuse; then
+ rm doc/man/acngfs.8 || die
+ fi
+
+ if use !doc; then
+ rm -r doc/html || die
+ fi
+
+ dosbin scripts/expire-caller.pl
+
+ keepdir "/var/log/${PN}"
+ fowners -R ${PN}:${PN} "/var/log/${PN}"
+
+ cmake_src_install
+}
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-9999999.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-9999999.ebuild
deleted file mode 100644
index 8ecaae37d3c5..000000000000
--- a/net-misc/apt-cacher-ng/apt-cacher-ng-9999999.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit cmake git-r3 user
-
-DESCRIPTION="Yet another caching HTTP proxy for Debian/Ubuntu software packages"
-HOMEPAGE="
- https://www.unix-ag.uni-kl.de/~bloch/acng/
- https://packages.qa.debian.org/a/apt-cacher-ng.html
-"
-LICENSE="BSD-4 ZLIB public-domain"
-SLOT="0"
-EGIT_REPO_URI="https://salsa.debian.org/blade/apt-cacher-ng.git"
-EGIT_BRANCH="upstream/sid"
-
-KEYWORDS=""
-IUSE="doc fuse systemd tcpd"
-
-COMMON_DEPEND="
- app-arch/bzip2
- app-arch/xz-utils
- dev-libs/libevent:=
- dev-libs/openssl:0=
- sys-libs/zlib
- systemd? (
- sys-apps/systemd
- )
-"
-BDEPEND="
- ${COMMON_DEPEND}
- virtual/pkgconfig
-"
-RDEPEND="
- ${COMMON_DEPEND}
- dev-lang/perl
- fuse? ( sys-fs/fuse )
- tcpd? ( sys-apps/tcp-wrappers )
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-3.5-perl-syntax.patch
- "${FILESDIR}"/${PN}-9999999-flags.patch
-)
-S=${WORKDIR}/${P/_*}
-
-pkg_setup() {
- # add new user & group for daemon
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_configure() {
- local mycmakeargs=(
- "-DCMAKE_SKIP_BUILD_RPATH=on"
- )
- if use fuse; then
- mycmakeargs+=( "-DHAVE_FUSE_25=yes" )
- else
- mycmakeargs+=( "-DHAVE_FUSE_25=no" )
- fi
- if use tcpd; then
- mycmakeargs+=( "-DHAVE_LIBWRAP=yes" )
- else
- mycmakeargs+=( "-DHAVE_LIBWRAP=no" )
- fi
-
- cmake_src_configure
-
- sed -i -e '/LogDir/s|/var/tmp|/var/log/'"${PN}"'|g' "${BUILD_DIR}"/conf/acng.conf || die
-}
-
-src_install() {
- pushd "${BUILD_DIR}" || die
- dosbin ${PN} acngtool
- dolib.so libsupacng.so
- if use fuse; then
- dobin acngfs
- fi
- popd || die
-
- newinitd "${FILESDIR}"/initd-r2 ${PN}
- newconfd "${FILESDIR}"/confd-r1 ${PN}
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/logrotate ${PN}
-
- doman doc/man/${PN}*
- if use fuse; then
- doman doc/man/acngfs*
- fi
-
- # Documentation
- dodoc doc/README TODO VERSION INSTALL ChangeLog
- if use doc; then
- dodoc doc/*.pdf
-
- docinto html
- dodoc doc/html/*
-
- find conf -name '*.gz' -exec gzip -d {} \; || die
- docinto examples/conf
- dodoc conf/*
- fi
-
- # perl daily cron script
- dosbin scripts/expire-caller.pl
- insinto /etc/cron.daily
- newins "${FILESDIR}"/cron.daily ${PN}
-
- # default configuration
- insinto /etc/${PN}
- newins "${BUILD_DIR}"/conf/acng.conf ${PN}.conf
- doins $( echo conf/* | sed 's|conf/acng.conf.in||g' )
-
- keepdir /var/log/${PN}
- # Some directories must exists
- keepdir /var/log/${PN}
- fowners -R ${PN}:${PN} \
- /etc/${PN} \
- /var/log/${PN}
-}