summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-26 15:18:21 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-26 15:19:16 +0200
commit61a8ef12e3fcbd7b4393d2983b04892cd45c36b0 (patch)
tree732f06f636ab4aa168ecfcd0a68c2e7aad9070d2 /net-misc/apt-cacher-ng
parentwww-client/opera-developer: Version 70.0.3701.0 (diff)
downloadgentoo-61a8ef12e3fcbd7b4393d2983b04892cd45c36b0.tar.gz
gentoo-61a8ef12e3fcbd7b4393d2983b04892cd45c36b0.tar.bz2
gentoo-61a8ef12e3fcbd7b4393d2983b04892cd45c36b0.zip
net-misc/apt-cacher-ng: Fix expire-caller.pl, disable by default
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/apt-cacher-ng')
-rw-r--r--net-misc/apt-cacher-ng/apt-cacher-ng-3.5_p1-r1.ebuild (renamed from net-misc/apt-cacher-ng/apt-cacher-ng-3.5_p1.ebuild)5
-rw-r--r--net-misc/apt-cacher-ng/apt-cacher-ng-9999999.ebuild5
-rw-r--r--net-misc/apt-cacher-ng/files/apt-cacher-ng-3.5-perl-syntax.patch11
3 files changed, 17 insertions, 4 deletions
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-3.5_p1.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-3.5_p1-r1.ebuild
index 4061fff1f9ca..97eab60040b8 100644
--- a/net-misc/apt-cacher-ng/apt-cacher-ng-3.5_p1.ebuild
+++ b/net-misc/apt-cacher-ng/apt-cacher-ng-3.5_p1-r1.ebuild
@@ -43,6 +43,7 @@ RDEPEND="
"
PATCHES=(
"${FILESDIR}"/${PN}-3.3.1-flags.patch
+ "${FILESDIR}"/${PN}-3.5-perl-syntax.patch
"${WORKDIR}"/debian/patches/debian-changes
)
S=${WORKDIR}/${P/_*}
@@ -121,8 +122,8 @@ src_install() {
# perl daily cron script
dosbin scripts/expire-caller.pl
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/cron.daily ${PN}
+ insinto /etc/cron.daily
+ doins "${FILESDIR}"/cron.daily ${PN}
# default configuration
insinto /etc/${PN}
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-9999999.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-9999999.ebuild
index 402b95991acf..9740af934f32 100644
--- a/net-misc/apt-cacher-ng/apt-cacher-ng-9999999.ebuild
+++ b/net-misc/apt-cacher-ng/apt-cacher-ng-9999999.ebuild
@@ -40,6 +40,7 @@ RDEPEND="
tcpd? ( sys-apps/tcp-wrappers )
"
PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-perl-syntax.patch
"${FILESDIR}"/${PN}-9999999-flags.patch
)
S=${WORKDIR}/${P/_*}
@@ -113,8 +114,8 @@ src_install() {
# perl daily cron script
dosbin scripts/expire-caller.pl
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/cron.daily ${PN}
+ insinto /etc/cron.daily
+ doins "${FILESDIR}"/cron.daily ${PN}
# default configuration
insinto /etc/${PN}
diff --git a/net-misc/apt-cacher-ng/files/apt-cacher-ng-3.5-perl-syntax.patch b/net-misc/apt-cacher-ng/files/apt-cacher-ng-3.5-perl-syntax.patch
new file mode 100644
index 000000000000..32421a07eefc
--- /dev/null
+++ b/net-misc/apt-cacher-ng/files/apt-cacher-ng-3.5-perl-syntax.patch
@@ -0,0 +1,11 @@
+--- a/scripts/expire-caller.pl
++++ b/scripts/expire-caller.pl
+@@ -1,7 +1,7 @@
+ #!/usr/bin/perl
+ #
+
+-print STDERR "WARNING: this script is considered deprecated. It may still work but could print incorrect results!\n"
++print STDERR "WARNING: this script is considered deprecated. It may still work but could print incorrect results!\n";
+
+ use strict;
+ use Socket;