summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/apt-proxy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/apt-proxy')
-rw-r--r--net-misc/apt-proxy/Manifest1
-rw-r--r--net-misc/apt-proxy/apt-proxy-1.3.0.ebuild70
-rw-r--r--net-misc/apt-proxy/files/apt-proxy17
-rw-r--r--net-misc/apt-proxy/files/apt-proxy-1.3.0-sh.patch11
-rw-r--r--net-misc/apt-proxy/metadata.xml10
5 files changed, 109 insertions, 0 deletions
diff --git a/net-misc/apt-proxy/Manifest b/net-misc/apt-proxy/Manifest
new file mode 100644
index 000000000000..07bac2357095
--- /dev/null
+++ b/net-misc/apt-proxy/Manifest
@@ -0,0 +1 @@
+DIST apt-proxy_1.3.0.tar.gz 37951 SHA256 12e5c5361ba3050a715f21c8191a1f52e255d179af10e3d110271651cb739ea9 SHA512 300d4684e726f0ac6ece0cf9dfe5c805f187651d36a38530cdf125f730f6c261dc1edd7ac5c0f54d6396a6aa8e3f007fa70a4c90e96bf672dfe9081c9a5b36d0 WHIRLPOOL 407a76367657baca536e5b753ea5ff01b9571d34f1b1d37d163c4586c09bd6a99168754ab22937994677e445941252374800d50258d61e4e5341a2b5865e67d4
diff --git a/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild b/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild
new file mode 100644
index 000000000000..dd454bee1532
--- /dev/null
+++ b/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils user
+
+DESCRIPTION="Caching proxy for the Debian package system"
+HOMEPAGE="http://sourceforge.net/projects/apt-proxy/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/xinetd"
+
+pkg_setup () {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sh.patch
+}
+
+src_install() {
+ dosbin ${PN}
+
+ insinto /etc/${PN}
+ doins ${PN}.conf
+
+ insinto /etc/xinetd.d
+ doins "${FILESDIR}"/${PN}
+
+ dodoc README INSTALL HISTORY
+ doman ${PN}.{8,conf.5}
+
+ # Create the log file with the proper permissions
+ dodir /var/log
+ touch "${D}"/var/log/${PN}.log
+ fowners ${PN}:${PN} /var/log/${PN}.log
+
+ # Create the cache directories and set the proper permissions
+ dodir /var/cache/${PN}
+ keepdir /var/cache/${PN}
+ fowners ${PN}:${PN} /var/cache/${PN}
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Don't forget to modify the /etc/${PN}/${PN}.conf"
+ einfo "file to fit your needs..."
+ einfo ""
+ einfo "Also note that ${PN} is called from running xinetd"
+ einfo "and you have to enable it first (/etc/xinetd.d/${PN})..."
+ einfo ""
+}
+
+pkg_postrm() {
+ einfo ""
+ einfo "You have to remove the ${PN} cache by hand. It's located"
+ einfo "in the \"/var/cache/${PN}\" dir..."
+ einfo ""
+ einfo "You can also remove the ${PN} user and group..."
+ einfo ""
+}
diff --git a/net-misc/apt-proxy/files/apt-proxy b/net-misc/apt-proxy/files/apt-proxy
new file mode 100644
index 000000000000..40db15ac96e9
--- /dev/null
+++ b/net-misc/apt-proxy/files/apt-proxy
@@ -0,0 +1,17 @@
+# default: off
+# description: this is a proxy for debian packages.
+# $Id$
+
+service apt-proxy
+{
+ type = UNLISTED
+ port = 9999
+ protocol = tcp
+ socket_type = stream
+ only_from = 0.0.0.0
+ wait = no
+ user = apt-proxy
+ server = /usr/sbin/apt-proxy
+ server_args = /var/log/apt-proxy.log
+ disable = yes
+}
diff --git a/net-misc/apt-proxy/files/apt-proxy-1.3.0-sh.patch b/net-misc/apt-proxy/files/apt-proxy-1.3.0-sh.patch
new file mode 100644
index 000000000000..9f6b97625af3
--- /dev/null
+++ b/net-misc/apt-proxy/files/apt-proxy-1.3.0-sh.patch
@@ -0,0 +1,11 @@
+--- apt-proxy 2002-04-04 14:30:19.000000000 +0200
++++ apt-proxy.new 2003-03-13 00:49:48.000000000 +0100
+@@ -1,5 +1,7 @@
+-#!/bin/ash
++#!/bin/sh
+ # (You may safely change the above to /bin/sh if you do not have ash available)
++### I really modified it (was /bin/ash)
++### Radek Podgorny <radek@podgorny.cz> (for Gentoo)
+ #
+ # $Id$
+ # Copyright Paul Russell <rusty@samba.org>
diff --git a/net-misc/apt-proxy/metadata.xml b/net-misc/apt-proxy/metadata.xml
new file mode 100644
index 000000000000..f270708b4def
--- /dev/null
+++ b/net-misc/apt-proxy/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">apt-proxy</remote-id>
+ </upstream>
+</pkgmetadata>