summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/asterisk-rate_engine/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/asterisk-rate_engine/files')
-rw-r--r--net-misc/asterisk-rate_engine/files/rate-engine-0.5.4-astcfg.diff41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/asterisk-rate_engine/files/rate-engine-0.5.4-astcfg.diff b/net-misc/asterisk-rate_engine/files/rate-engine-0.5.4-astcfg.diff
new file mode 100644
index 000000000000..fe2772d660cc
--- /dev/null
+++ b/net-misc/asterisk-rate_engine/files/rate-engine-0.5.4-astcfg.diff
@@ -0,0 +1,41 @@
+--- rate-engine-0.5.4/Makefile.orig 2005-02-21 04:42:24.046680160 +0100
++++ rate-engine-0.5.4/Makefile 2005-02-21 04:47:38.049944408 +0100
+@@ -10,7 +10,7 @@
+
+ DEBUG+= -g -fno-inline-functions
+
+-CFLAGS+= -O3 -W -Wall -Wmissing-prototypes -Wstrict-prototypes -Wshadow \
++CFLAGS+= -fPIC -W -Wall -Wmissing-prototypes -Wstrict-prototypes -Wshadow \
+ $(DEBUG) -D_REENTRANT -I/usr/include/pcre
+ LDFLAGS+= $(DEBUG)
+ LDLIBS+= -lpthread
+@@ -26,9 +26,9 @@
+ OBJS:= $(SRCS:%.c=%.o)
+ MOD= rate_engine.so
+
+-ASTLIBDIR= /usr/lib/asterisk/modules
+-ASTCONFDIR= /etc/asterisk
+-BINDIR= /usr/bin
++ASTLIBDIR= $(shell /usr/bin/asterisk-config --modulesdir)
++ASTCONFDIR= $(shell /usr/bin/asterisk-config --sysconfdir)
++BINDIR= $(shell /usr/bin/asterisk-config --bindir)
+
+ .PHONY: all
+
+@@ -50,12 +50,14 @@
+ .PHONY: install
+
+ install: all
+- install -m 755 $(MOD) $(ASTLIBDIR)
++ if [ ! -d $(DESTDIR)$(ASTLIBDIR) ]; then mkdir -p $(DESTDIR)$(ASTLIBDIR); fi
++ install -m 755 $(MOD) $(DESTDIR)$(ASTLIBDIR)
+
+ .PHONY: samples
+
+ samples:
+- install -m 644 rate_engine.conf.sample $(ASTCONFDIR)/rate_engine.conf
++ if [ ! -d $(DESTDIR)$(ASTCONFDIR) ]; then mkdir -p $(DESTDIR)$(ASTCONFDIR); fi
++ install -m 644 rate_engine.conf.sample $(DESTDIR)$(ASTCONFDIR)/rate_engine.conf
+
+ ifneq ($(wildcard .depend),)
+ include .depend