summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-06-14 11:59:51 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2020-06-14 12:00:20 +0200
commit548aa30eccc8723f44833e094138d7503472a61a (patch)
tree5b5bc93ad7ebb6b236930d3dc0d8e80074b01db7 /net-misc/axel/axel-2.17.9.ebuild
parentnet-libs/libnetfilter_queue: Version 1.0.5 (diff)
downloadgentoo-548aa30eccc8723f44833e094138d7503472a61a.tar.gz
gentoo-548aa30eccc8723f44833e094138d7503472a61a.tar.bz2
gentoo-548aa30eccc8723f44833e094138d7503472a61a.zip
net-misc/axel: 2.17.9 version bump.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-misc/axel/axel-2.17.9.ebuild')
-rw-r--r--net-misc/axel/axel-2.17.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/axel/axel-2.17.9.ebuild b/net-misc/axel/axel-2.17.9.ebuild
new file mode 100644
index 000000000000..dad9472d9679
--- /dev/null
+++ b/net-misc/axel/axel-2.17.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="https://github.com/axel-download-accelerator/axel"
+SRC_URI="https://github.com/axel-download-accelerator/axel/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug libressl nls ssl"
+
+CDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libintl virtual/libiconv )"
+
+DOCS=( doc/. )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl)
+}
+
+pkg_postinst() {
+ einfo 'To use axel with Portage, one can configure make.conf with:'
+ einfo
+ einfo 'FETCHCOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+ einfo 'RESUMECOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+}