summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-10 11:55:44 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-10 11:59:05 -0500
commitf9cccdf7058539ac74a130d145d72349174f385a (patch)
tree7ab37221c6d58010fb61b84f0ccb5d53912214fd /net-misc/bfgminer
parentdev-python/html2text: Upstream tarball changed (diff)
downloadgentoo-f9cccdf7058539ac74a130d145d72349174f385a.tar.gz
gentoo-f9cccdf7058539ac74a130d145d72349174f385a.tar.bz2
gentoo-f9cccdf7058539ac74a130d145d72349174f385a.zip
net-misc/bfgminer: version bump to 5.5.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'net-misc/bfgminer')
-rw-r--r--net-misc/bfgminer/Manifest1
-rw-r--r--net-misc/bfgminer/bfgminer-5.5.0.ebuild195
-rw-r--r--net-misc/bfgminer/metadata.xml2
3 files changed, 198 insertions, 0 deletions
diff --git a/net-misc/bfgminer/Manifest b/net-misc/bfgminer/Manifest
index 0ffa766568b6..d228402fb3bc 100644
--- a/net-misc/bfgminer/Manifest
+++ b/net-misc/bfgminer/Manifest
@@ -1 +1,2 @@
DIST bfgminer-5.4.2.tar.xz 1039200 BLAKE2B f63a7fa2c85d352a366794a39619599db6ccc3f98508ccd90387b315374227d74edfcfd2329db8b57c96539b194b0d2ee746cbea032c241dab1cf93e717b137d SHA512 b5ae8ae44df166d5576f89683ce9ee0832ca1f506b2522da7e3cd432abc5e218e9080e2a79f4da29e40db0d3179e63c9a8907d5d6b60d5d4895d6cac2b15d8ca
+DIST bfgminer-5.5.0.tar.xz 1054664 BLAKE2B db841a73bca10b19205744be531c13f2c4435bd69c9f2af7b8aba84381af640028cc4db33df399cf05dd0bbec7b79a5b65679bcb2a8bec7624f6fbc47e9ebd79 SHA512 d1adae473e01fcf1cd0efde74d3e8ce10609e520397d688bf4e226c1113c1606c782e3cfdba6847f1a3886cac30de6b5baa03b731aca86287d53bf01ef705cdb
diff --git a/net-misc/bfgminer/bfgminer-5.5.0.ebuild b/net-misc/bfgminer/bfgminer-5.5.0.ebuild
new file mode 100644
index 000000000000..44b0c667244e
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-5.5.0.ebuild
@@ -0,0 +1,195 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.txz -> ${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+# TODO: knc (needs i2c-tools header)
+# TODO: kncasic & titan (need systemwide knc-asic install)
+# TODO: minergate (needs actual miner_gate)
+IUSE="adl alchemist avalon avalonmm bitmain bfsb bfx bifury bigpic bitforce bitfury cointerra cpumining drillbit dualminer examples gridseed hardened hashbuster hashbuster2 hashfast icarus jingtian keccak klondike +libusb littlefury lm_sensors metabank minion modminer nanofury ncurses opencl proxy proxy_getwork proxy_stratum rockminer screen scrypt +sha256d twinfury +udev udev-broad-rules unicode x6500 zeusminer ztex"
+REQUIRED_USE='
+ || ( keccak scrypt sha256d )
+ || ( alchemist avalon avalonmm bitmain bfsb bfx bifury bigpic bitforce bitfury cointerra cpumining drillbit dualminer gridseed hashbuster hashbuster2 hashfast icarus klondike littlefury metabank modminer nanofury opencl proxy twinfury x6500 zeusminer ztex )
+ adl? ( opencl )
+ alchemist? ( scrypt )
+ avalon? ( sha256d )
+ avalonmm? ( sha256d )
+ bitmain? ( sha256d )
+ bfsb? ( sha256d bitfury )
+ bfx? ( sha256d bitfury libusb )
+ bifury? ( sha256d )
+ bigpic? ( sha256d bitfury )
+ bitforce? ( sha256d )
+ bitfury? ( sha256d )
+ cointerra? ( sha256d )
+ drillbit? ( sha256d bitfury )
+ dualminer? ( || ( sha256d scrypt ) icarus )
+ gridseed? ( scrypt )
+ hashbuster? ( sha256d bitfury )
+ hashbuster2? ( sha256d bitfury libusb )
+ hashfast? ( sha256d )
+ icarus? ( || ( scrypt sha256d ) )
+ jingtian? ( sha256d )
+ keccak? ( || ( cpumining opencl proxy ) )
+ klondike? ( sha256d libusb )
+ littlefury? ( sha256d bitfury )
+ lm_sensors? ( opencl )
+ metabank? ( sha256d bitfury )
+ minion? ( sha256d )
+ modminer? ( sha256d )
+ nanofury? ( sha256d bitfury )
+ scrypt? ( || ( cpumining dualminer gridseed opencl proxy zeusminer ) )
+ sha256d? ( || ( avalon avalonmm bitmain bfx bifury bitforce bfsb bigpic bitfury cointerra cpumining drillbit dualminer hashbuster hashbuster2 hashfast icarus jingtian klondike littlefury metabank modminer nanofury opencl proxy rockminer twinfury x6500 ztex ) )
+ unicode? ( ncurses )
+ proxy? ( || ( proxy_getwork proxy_stratum ) )
+ proxy_getwork? ( proxy )
+ proxy_stratum? ( proxy )
+ rockminer? ( sha256d )
+ twinfury? ( bitfury sha256d )
+ x6500? ( sha256d libusb )
+ zeusminer? ( scrypt icarus )
+ ztex? ( sha256d libusb )
+'
+
+DEPEND='
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses:=[unicode?]
+ )
+ >=dev-libs/jansson-2
+ dev-libs/libbase58
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ hashbuster? (
+ dev-libs/hidapi
+ )
+ libusb? (
+ virtual/libusb:1
+ )
+ lm_sensors? (
+ sys-apps/lm_sensors
+ )
+ nanofury? (
+ dev-libs/hidapi
+ )
+ proxy_getwork? (
+ net-libs/libmicrohttpd
+ )
+ proxy_stratum? (
+ dev-libs/libevent
+ )
+ screen? (
+ app-misc/screen
+ || (
+ >=sys-apps/coreutils-8.15
+ sys-freebsd/freebsd-bin
+ app-misc/realpath
+ )
+ )
+'
+RDEPEND="${DEPEND}
+ opencl? (
+ || (
+ virtual/opencl
+ dev-util/nvidia-cuda-sdk[opencl]
+ )
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/uthash-1.9.7
+ sys-apps/sed
+ cpumining? (
+ amd64? (
+ >=dev-lang/yasm-1.0.1
+ )
+ x86? (
+ >=dev-lang/yasm-1.0.1
+ )
+ )
+"
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ local with_curses
+ use hardened && CFLAGS="${CFLAGS} -no-pie"
+
+ if use ncurses; then
+ if use unicode; then
+ with_curses='--with-curses=ncursesw'
+ else
+ with_curses='--with-curses=ncurses'
+ fi
+ else
+ with_curses='--without-curses'
+ fi
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable adl) \
+ $(use_enable alchemist)\
+ $(use_enable avalon) \
+ $(use_enable avalonmm) \
+ $(use_enable bifury) \
+ $(use_enable bitforce) \
+ $(use_enable bitmain) \
+ $(use_enable bfsb) \
+ $(use_enable bfx) \
+ $(use_enable bigpic) \
+ $(use_enable bitfury) \
+ $(use_enable cointerra) \
+ $(use_enable cpumining) \
+ $(use_enable drillbit) \
+ $(use_enable dualminer) \
+ $(use_enable gridseed) \
+ $(use_enable hashbuster) \
+ $(use_enable hashbuster2 hashbusterusb) \
+ $(use_enable hashfast) \
+ $(use_enable icarus) \
+ $(use_enable jingtian) \
+ $(use_enable keccak) \
+ $(use_enable klondike) \
+ $(use_enable littlefury) \
+ $(use_enable metabank) \
+ $(use_enable minion) \
+ $(use_enable modminer) \
+ $(use_enable nanofury) \
+ $(use_enable opencl) \
+ $(use_enable rockminer) \
+ $(use_enable scrypt) \
+ $(use_enable sha256d) \
+ $(use_enable twinfury) \
+ --with-system-libblkmaker \
+ $with_curses \
+ $(use_with udev libudev) \
+ $(use_enable udev-broad-rules broad-udevrules) \
+ $(use_with lm_sensors sensors) \
+ $(use_with proxy_getwork libmicrohttpd) \
+ $(use_with proxy_stratum libevent) \
+ $(use_enable x6500) \
+ $(use_enable zeusminer) \
+ $(use_enable ztex)
+}
+
+src_install() {
+ emake install DESTDIR="$D"
+ if ! use examples; then
+ rm -r "${D}/usr/share/doc/${PF}/rpc-examples"
+ fi
+ if ! use screen; then
+ rm "${D}/usr/bin/start-bfgminer.sh"
+ fi
+}
diff --git a/net-misc/bfgminer/metadata.xml b/net-misc/bfgminer/metadata.xml
index aa456e90bcef..0a9f60a01dab 100644
--- a/net-misc/bfgminer/metadata.xml
+++ b/net-misc/bfgminer/metadata.xml
@@ -11,11 +11,13 @@
</maintainer>
<use>
<flag name="adl">Enable support for controlling fans and overclocking on AMD cards with AMD Display Library</flag>
+ <flag name="alchemist">Enable support for mining with AlcheMist</flag>
<flag name="antminer">Enable support for mining with AntMiner U1 sticks</flag>
<flag name="avalon">Enable support for mining with Avalon 1 ASIC modules</flag>
<flag name="avalonmm">Enable support for mining with Avalon 2/3 ASIC modules</flag>
<flag name="bifury">Enable support for mining with Bi*fury USB sticks</flag>
<flag name="bitforce">Enable support for mining with ButterFly Labs BitFORCE ASICs and/or FPGAs</flag>
+ <flag name="bitmain">Enable support for mining with Bitmain Antminer S* series</flag>
<flag name="bfsb">Enable support for mining on BFSB host Raspberry Pi</flag>
<flag name="bfx">Enable support for mining with BFx2 USB sticks</flag>
<flag name="bigpic">Enable support for mining with Big Picture Mining USB sticks (Red/BlueFury, BF1, etc)</flag>