summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2020-02-10 13:53:17 +0000
committerTony Vroon <chainsaw@gentoo.org>2020-02-10 13:53:17 +0000
commit04dd55d527f2e49961ad32cd156148db82b04b0a (patch)
tree9f4024c718dc1613e8b69b879eb33675a9b00b06 /net-misc/bird/bird-2.0.7.ebuild
parentapp-admin/ansible-lint: Version bump to 4.1.0 (diff)
downloadgentoo-04dd55d527f2e49961ad32cd156148db82b04b0a.tar.gz
gentoo-04dd55d527f2e49961ad32cd156148db82b04b0a.tar.bz2
gentoo-04dd55d527f2e49961ad32cd156148db82b04b0a.zip
net-misc/bird: Version bump to 2.0.7
Version 2.0.7 (2019-10-11) o BGP: Accumulated IGP metric (RFC 7311) o Important filter reconfiguration bugfix o Several other bugfixes Version 2.0.6 (2019-09-10) o RAdv: Solicited unicast RAs o BGP: Optional Adj-RIB-Out o BGP: Extended optional parameters length o Filter: Sets and set expressions in path masks o Several important bugfixes Version 2.0.5 (2019-08-01) o OSPF Graceful restart (RFC 3623, RFC 5187) o BGP: Dynamic BGP o BGP: Promiscuous ASN mode o BGP: Mandatory option for channels o BFD: Support for VRFs o Graceful restart command o Redesigned filtering code o Many bugfixes Notes: Previous version introduced an error in handling of OSPF NSSA-LSA, causing compatibility issues with proper implementations. The error is fixed in this version, therefore there are compatibility issues in OSPF NSSA areas between this and previous version. Signed-Off-By: Tony Vroon <chainsaw@gentoo.org> Package-Manager: Portage-2.3.84, Repoman-2.3.20
Diffstat (limited to 'net-misc/bird/bird-2.0.7.ebuild')
-rw-r--r--net-misc/bird/bird-2.0.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/bird/bird-2.0.7.ebuild b/net-misc/bird/bird-2.0.7.ebuild
new file mode 100644
index 000000000000..edc17f5b33c7
--- /dev/null
+++ b/net-misc/bird/bird-2.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 & IPv6"
+HOMEPAGE="http://bird.network.cz"
+SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~x64-macos"
+IUSE="+client debug"
+
+RDEPEND="client? ( sys-libs/ncurses )
+ client? ( sys-libs/readline )"
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-devel/m4"
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable client) \
+ $(use_enable debug)
+}
+
+src_install() {
+ if use client; then
+ dobin birdc
+ fi
+ dobin birdcl
+ dosbin bird
+ newinitd "${FILESDIR}/initd-${PN}-2" bird
+ dodoc doc/bird.conf.example
+}