summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2016-05-22 17:38:20 +0200
committerTobias Klausmann <klausman@gentoo.org>2016-05-22 17:38:20 +0200
commit0909acacf126718591b95aaf3caf7467abdf4ae1 (patch)
tree35a1d140f0bfe021859f7e4c6a67d4eabefc0f18 /net-misc/chrony
parentmedia-gfx/imagemagick: Bump to versions 6.9.4.4 and 7.0.1.6 (diff)
downloadgentoo-0909acacf126718591b95aaf3caf7467abdf4ae1.tar.gz
gentoo-0909acacf126718591b95aaf3caf7467abdf4ae1.tar.bz2
gentoo-0909acacf126718591b95aaf3caf7467abdf4ae1.zip
net-misc/chrony: Modify logrotate script to suppress spurious mails
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/chrony-2.4_pre1-r1.ebuild118
-rw-r--r--net-misc/chrony/files/chrony-2.4.logrotate7
2 files changed, 125 insertions, 0 deletions
diff --git a/net-misc/chrony/chrony-2.4_pre1-r1.ebuild b/net-misc/chrony/chrony-2.4_pre1-r1.ebuild
new file mode 100644
index 000000000000..7d20e2029988
--- /dev/null
+++ b/net-misc/chrony/chrony-2.4_pre1-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~hppa ~ppc64"
+IUSE="caps +cmdmon html ipv6 libedit +ntp +phc +pps readline +refclock +rtc selinux +adns"
+REQUIRED_USE="
+ ?? ( libedit readline )
+"
+
+CDEPEND="
+ caps? ( sys-libs/libcap )
+ libedit? ( dev-libs/libedit )
+ readline? ( >=sys-libs/readline-4.1-r4:= )
+"
+DEPEND="
+ ${CDEPEND}
+ html? ( dev-ruby/asciidoctor )
+"
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-chronyd )
+"
+
+RESTRICT=test
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ sed -i \
+ -e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
+ -e 's:/var/run:/run:g' \
+ conf.c doc/*.man.in examples/* || die
+}
+
+src_configure() {
+ tc-export CC
+
+ local CHRONY_EDITLINE
+ # ./configure legend:
+ # --disable-readline : disable line editing entirely
+ # --without-readline : do not use sys-libs/readline (enabled by default)
+ # --without-editline : do not use dev-libs/libedit (enabled by default)
+ if ! use readline && ! use libedit; then
+ CHRONY_EDITLINE='--disable-readline'
+ else
+ CHRONY_EDITLINE+=" $(usex readline '' --without-readline)"
+ CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
+ fi
+
+ # not an autotools generated script
+ local CHRONY_CONFIGURE="
+ ./configure \
+ $(usex caps '' --disable-linuxcaps) \
+ $(usex cmdmon '' --disable-cmdmon) \
+ $(usex ipv6 '' --disable-ipv6) \
+ $(usex ntp '' --disable-ntp) \
+ $(usex phc '' --disable-phc) \
+ $(usex pps '' --disable-pps) \
+ $(usex rtc '' --disable-rtc) \
+ $(usex refclock '' --disable-refclock) \
+ $(usex adns '' --disable-asyncdns) \
+ ${CHRONY_EDITLINE} \
+ ${EXTRA_ECONF} \
+ --docdir=/usr/share/doc/${PF} \
+ --chronysockdir=/run/chrony \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --sysconfdir=/etc/chrony \
+ --disable-sechash \
+ --without-nss \
+ --without-tomcrypt
+ "
+
+ # print the ./configure call to aid in future debugging
+ einfo ${CHRONY_CONFIGURE}
+ bash ${CHRONY_CONFIGURE} || die
+}
+
+src_compile() {
+ emake all docs $(usex html '' 'ADOC=true')
+
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/chronyd.init-r1 chronyd
+ newconfd "${FILESDIR}"/chronyd.conf chronyd
+
+ insinto /etc/${PN}
+ newins examples/chrony.conf.example1 chrony.conf
+
+ docinto examples
+ dodoc examples/*.example*
+
+ if use html; then
+ docinto html
+ dodoc doc/*.html
+ fi
+
+ keepdir /var/{lib,log}/chrony
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/chrony-2.4.logrotate chrony
+
+ systemd_newunit "${FILESDIR}"/chronyd.service-r2 chronyd.service
+ systemd_enable_ntpunit 50-chrony chronyd.service
+}
diff --git a/net-misc/chrony/files/chrony-2.4.logrotate b/net-misc/chrony/files/chrony-2.4.logrotate
new file mode 100644
index 000000000000..d1ae72b6e7a1
--- /dev/null
+++ b/net-misc/chrony/files/chrony-2.4.logrotate
@@ -0,0 +1,7 @@
+/var/log/chrony/*.log {
+ missingok
+ sharedscripts
+ postrotate
+ /usr/bin/chronyc cyclelogs |grep -v '^200 OK'
+ endscript
+}