summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <crabbedhaloablution@icloud.com>2020-12-15 12:46:03 +0100
committerSam James <sam@gentoo.org>2021-02-08 14:53:59 +0000
commite69294ba7087691b826ad8ed73dac52c9a3527aa (patch)
treefe96cbf3012cee431eeafadb6bbe53124a965732 /net-misc/chrony
parentnet-misc/chrony: add nss support (diff)
downloadgentoo-e69294ba7087691b826ad8ed73dac52c9a3527aa.tar.gz
gentoo-e69294ba7087691b826ad8ed73dac52c9a3527aa.tar.bz2
gentoo-e69294ba7087691b826ad8ed73dac52c9a3527aa.zip
net-misc/chrony: enable NTS support
Enabled NTS support in ebuild. Needs net-libs/gnutls and dev-libs/nettle. NTS is the only thing net-libs/gnutls is used for. Reported-By: Matt Whitlock <gentoo@mattwhitlock.name> Closes: https://bugs.gentoo.org/759526 Signed-off-by: Peter Alfredsen <crabbedhaloablution@icloud.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/chrony-9999.ebuild6
-rw-r--r--net-misc/chrony/metadata.xml3
2 files changed, 7 insertions, 2 deletions
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index 81b51b9af840..650ad8c14157 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -20,12 +20,13 @@ S="${WORKDIR}/${P/_/-}"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+caps +cmdmon html ipv6 libedit +nettle nss +ntp +phc pps +refclock +rtc samba +seccomp +sechash selinux"
+IUSE="+caps +cmdmon html ipv6 libedit +nettle nss +ntp +phc +nts pps +refclock +rtc samba +seccomp +sechash selinux"
REQUIRED_USE="
sechash? ( || ( nettle nss ) )
nettle? ( !nss )
!sechash? ( !nss )
!sechash? ( !nts? ( !nettle ) )
+ nts? ( nettle )
"
RESTRICT="test"
@@ -43,6 +44,7 @@ DEPEND="
acct-user/ntp
sys-libs/libcap
)
+ nts? ( net-libs/gnutls:= )
libedit? ( dev-libs/libedit )
nettle? ( dev-libs/nettle:= )
nss? ( dev-libs/nss:= )
@@ -100,6 +102,8 @@ src_configure() {
$(usex nettle '' --without-nettle)
$(usex nss '' --without-nss)
$(usex ntp '' --disable-ntp)
+ $(usex nts '' --disable-nts)
+ $(usex nts '' --without-gnutls)
$(usex phc '' --disable-phc)
$(usex pps '' --disable-pps)
$(usex refclock '' --disable-refclock)
diff --git a/net-misc/chrony/metadata.xml b/net-misc/chrony/metadata.xml
index fe7394a48bfa..791c4d1271b8 100644
--- a/net-misc/chrony/metadata.xml
+++ b/net-misc/chrony/metadata.xml
@@ -25,9 +25,10 @@
<use>
<flag name="cmdmon">Support for command and monitoring</flag>
<flag name="html">Install HTML documentation</flag>
- <flag name="nettle">Use <pkg>dev-libs/nettle</pkg> for hash functions</flag>
+ <flag name="nettle">Use <pkg>dev-libs/nettle</pkg> for hash functions or nts</flag>
<flag name="nss">Use <pkg>dev-libs/nss</pkg> for hash functions</flag>
<flag name="ntp">Support for the Network Time Protocol (NTP)</flag>
+ <flag name="nts">Support for Network Time Security (NTS). Uses <pkg>net-libs/gnutls</pkg></flag>
<flag name="phc">Support for the PTP (Precision Time Protocol) Hardware Clock (PHC) interface</flag>
<flag name="pps">Support for the Linux Pulse Per Second (PPS) interface</flag>
<flag name="refclock">Support for reference clocks</flag>