summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/dropbox-cli
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/dropbox-cli')
-rw-r--r--net-misc/dropbox-cli/Manifest2
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-1-r1.ebuild29
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-1.6.0.ebuild29
-rw-r--r--net-misc/dropbox-cli/metadata.xml8
4 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/dropbox-cli/Manifest b/net-misc/dropbox-cli/Manifest
new file mode 100644
index 000000000000..c322b75e5729
--- /dev/null
+++ b/net-misc/dropbox-cli/Manifest
@@ -0,0 +1,2 @@
+DIST dropbox-cli-1.6.0.py.xz 17632 SHA256 0030e948dbc6795fecde32c41a7c0779f3ec5131473fa4039ae9356e7238b3d6 SHA512 06fcbba67031c18fe1840f592d04039a7c78848d6e77ae8cca04881f5f72ada7fb368921e2ae3b92d161e49bf91eae0f41b559a210eacd0dc203c51134597857 WHIRLPOOL a0af611c354474e5bec27796bf07933de64d6bd8f3c04641238c8f5149111daf5b1f93a2b33bdc3c89f5386f7a864e7edfa0d9d784f72a2c2b1db9250bdfa6c7
+DIST dropbox-cli-1.py.xz 17580 SHA256 4773944647444b2fafef0b2db36cab6605de8ca6557d824d527e3725d65eecfe SHA512 d5510a66a5605e474059bb761cc2f33cd4d23481e85f040b049c36759a030f1e7072a9ad2cc7f72e59507767aa375ff3ea1c06d7bf702eb7ba7d698db2bfefe5 WHIRLPOOL 50740fa16f669321bf16a69358e8cada1f11c77f984b138b6ec0ff7a0c99f84d1515ddeab6483ffb578b5ccabe189def35b10d83a7c3b7a0d6e67e70c0675770
diff --git a/net-misc/dropbox-cli/dropbox-cli-1-r1.ebuild b/net-misc/dropbox-cli/dropbox-cli-1-r1.ebuild
new file mode 100644
index 000000000000..28283d740c02
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Cli interface for dropbox daemon (python)"
+HOMEPAGE="http://www.dropbox.com/"
+SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.py.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="net-misc/dropbox
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+}
diff --git a/net-misc/dropbox-cli/dropbox-cli-1.6.0.ebuild b/net-misc/dropbox-cli/dropbox-cli-1.6.0.ebuild
new file mode 100644
index 000000000000..3a2c266fea96
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-1.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Cli interface for dropbox (python), part of nautilus-dropbox"
+HOMEPAGE="http://www.dropbox.com/"
+SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.py.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="net-misc/dropbox
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+}
diff --git a/net-misc/dropbox-cli/metadata.xml b/net-misc/dropbox-cli/metadata.xml
new file mode 100644
index 000000000000..11d49ae49fab
--- /dev/null
+++ b/net-misc/dropbox-cli/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+