summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-04-13 07:51:16 +0000
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-21 01:23:44 -0700
commitaf3182b61d2db38d9ad2f4b37fb1196c2961f879 (patch)
treed6d42f3951766e9940d29b01c319f77ae5c4c334 /net-misc/endlessh
parentnet-ftp/ncftp: Update HOMEPAGE/SRC_URI/A (diff)
downloadgentoo-af3182b61d2db38d9ad2f4b37fb1196c2961f879.tar.gz
gentoo-af3182b61d2db38d9ad2f4b37fb1196c2961f879.tar.bz2
gentoo-af3182b61d2db38d9ad2f4b37fb1196c2961f879.zip
net-misc/endlessh: bump to 1.1
Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Closes: https://github.com/gentoo/gentoo/pull/15328 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-misc/endlessh')
-rw-r--r--net-misc/endlessh/Manifest1
-rw-r--r--net-misc/endlessh/endlessh-1.1.ebuild61
-rw-r--r--net-misc/endlessh/files/endlessh-1.1-syslog-help.patch24
-rw-r--r--net-misc/endlessh/files/endlessh.confd-r229
-rw-r--r--net-misc/endlessh/files/endlessh.initd-r230
5 files changed, 145 insertions, 0 deletions
diff --git a/net-misc/endlessh/Manifest b/net-misc/endlessh/Manifest
index 55b4df2b685f..24508ced9f3d 100644
--- a/net-misc/endlessh/Manifest
+++ b/net-misc/endlessh/Manifest
@@ -1 +1,2 @@
DIST endlessh-1.0.tar.gz 12258 BLAKE2B add6e24568cc94b244aa52bb484d1516210bfaa5a82440e090a89a94d50fbd4805ae004f917af56a7ad82a6502ae97c059d3f1c24b7c3e13ad1bd5a04bcf1c3e SHA512 a7e4e6ac5dc5e9b6e479ac3323b6a3ecec398ea074970de7794c93bd7a1a77c5662bdfa5752217fe552db1b3dbb9f400183114d7399c5a019637cb40756b46a8
+DIST endlessh-1.1.tar.gz 12844 BLAKE2B 8828739844cb03f67067bb020c3da5b5c6610a195202776da1ae184c0ab02c9f2acef32cc6536bbb80a46242251e3425eed2c70b0d1a90b0e73696ac14babc94 SHA512 7df2463425ad1417a2e328eacfb840aed14727168b83b5adf80cf6c5c98a6fc05f96bba9257b543ef60202a74383e4978e92c4a1b959e35d4ab94e0e5bda14fd
diff --git a/net-misc/endlessh/endlessh-1.1.ebuild b/net-misc/endlessh/endlessh-1.1.ebuild
new file mode 100644
index 000000000000..d4fc3553bf59
--- /dev/null
+++ b/net-misc/endlessh/endlessh-1.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="SSH tarpit that slowly sends and endless banner"
+HOMEPAGE="https://github.com/skeeto/endlessh"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/skeeto/${PN}.git"
+else
+ SRC_URI="https://github.com/skeeto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+LICENSE="Unlicense"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+BDEPEND=""
+
+src_prepare() {
+ default
+
+ tc-export CC
+
+ sed -i \
+ -e 's/^CC/CC?/' \
+ -e 's/^CFLAGS =/CFLAGS +=/' \
+ -e 's/ -Os//' \
+ -e 's/^LDFLAGS/LDFLAGS?/' \
+ -e 's/^PREFIX/PREFIX?/' \
+ Makefile || die
+
+ sed -i -e "/^ExecStart=/ s:=/opt/endlessh:=${EPREFIX}/usr/bin:" \
+ util/endlessh.service || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ einstalldocs
+
+ newinitd "${FILESDIR}"/endlessh.initd-r2 endlessh
+ newconfd "${FILESDIR}"/endlessh.confd-r2 endlessh
+
+ systemd_dounit util/endlessh.service
+
+ insinto /usr/share/"${PN}"
+ doins util/{pivot.py,schema.sql}
+}
+
+pkg_postinst() {
+ elog "Log parsing script installed to ${EPREFIX}/usr/share/${PN}"
+ elog "Install dev-python/pyrfc3339 if you are going to use it"
+}
diff --git a/net-misc/endlessh/files/endlessh-1.1-syslog-help.patch b/net-misc/endlessh/files/endlessh-1.1-syslog-help.patch
new file mode 100644
index 000000000000..ec87997d2f23
--- /dev/null
+++ b/net-misc/endlessh/files/endlessh-1.1-syslog-help.patch
@@ -0,0 +1,24 @@
+From 3643683c20774afa1606bae5f1c4ccbfd2a905db Mon Sep 17 00:00:00 2001
+From: "Sam James (sam_c)" <sam@cmpct.info>
+Date: Tue, 21 Apr 2020 08:09:49 +0000
+Subject: [PATCH] Add -s (syslog) to help output
+
+Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
+---
+ endlessh.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/endlessh.c b/endlessh.c
+index adb8ad3..8c3afff 100644
+--- a/endlessh.c
++++ b/endlessh.c
+@@ -530,6 +530,8 @@ usage(FILE *f)
+ fprintf(f, " -m INT Maximum number of clients ["
+ XSTR(DEFAULT_MAX_CLIENTS) "]\n");
+ fprintf(f, " -p INT Listening port [" XSTR(DEFAULT_PORT) "]\n");
++ fprintf(f, " -s Print diagnostics to syslog instead of "
++ "standard output\n");
+ fprintf(f, " -v Print diagnostics to standard output "
+ "(repeatable)\n");
+ fprintf(f, " -V Print version information and exit\n");
+
diff --git a/net-misc/endlessh/files/endlessh.confd-r2 b/net-misc/endlessh/files/endlessh.confd-r2
new file mode 100644
index 000000000000..062e30f0c164
--- /dev/null
+++ b/net-misc/endlessh/files/endlessh.confd-r2
@@ -0,0 +1,29 @@
+# /etc/conf.d/endlessh: config file for /etc/init.d/endlessh
+#
+#default options used by init.d if this is unset
+#ENDLESSH_ARGS="-sv"
+#
+#Usage: endlessh [-vh] [-46] [-d MS] [-f CONFIG] [-l LEN] [-m LIMIT] [-p PORT]
+# -4 Bind to IPv4 only
+# -6 Bind to IPv6 only
+# -d INT Message millisecond delay [10000]
+# -f Set and load config file [/etc/endlessh/config]
+# -h Print this help message and exit
+# -l INT Maximum banner line length (3-255) [32]
+# -m INT Maximum number of clients [4096]
+# -p INT Listening port [2222]
+# -v Print diagnostics to standard output (repeatable)
+# -V Print version information and exit
+
+# EXAMPLE 1: listen on port 22, log all queries and errors in very verbose mode
+#ENDLESSH_ARGS="-p 22 -vv"
+
+# EXAMPLE 2: load settings from config file
+#ENDLESSH_ARGS="-f /etc/endlessh/config"
+
+# EXAMPLE 3: load settings from config file, but override port
+#ENDLESSH_ARGS="-f /etc/endlessh/config -p 22"
+
+# LOGGING: by default is syslog
+# You can add -v (or -vv) for verbosity
+#ENDLESSH_ARGS="-s -v"
diff --git a/net-misc/endlessh/files/endlessh.initd-r2 b/net-misc/endlessh/files/endlessh.initd-r2
new file mode 100644
index 000000000000..0b995f683d91
--- /dev/null
+++ b/net-misc/endlessh/files/endlessh.initd-r2
@@ -0,0 +1,30 @@
+#!/sbin/openrc-run
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ after bootmisc
+ need localmount
+ use clock logger net
+}
+
+description="Starts endlessh tarpit"
+
+command="/usr/bin/endlessh"
+# NOTE: You will need to add -s to ENDLESSH_ARGS in /etc/conf.d/endlessh if modified to keep syslog
+command_args="${ENDLESSH_ARGS:--sv}"
+command_background="true"
+extra_started_commands="dumpstats reload"
+pidfile="/run/${RC_SVCNAME}.pid"
+
+dumpstats() {
+ ebegin "Dumping connection stats of ${RC_SVCNAME} to log"
+ start-stop-daemon --signal SIGUSR1 --pidfile "${pidfile}"
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${RC_SVCNAME} configuration"
+ start-stop-daemon --signal HUP --pidfile "${pidfile}"
+ eend $?
+}