summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-11-08 12:43:20 -0500
committerMike Gilbert <floppym@gentoo.org>2015-11-08 12:44:08 -0500
commita998d5281b750cc84c8d411d186a1d3fbebaf6a5 (patch)
treed08d4d994b8f29e44615f26cd93b85b4ecbc43f8 /net-misc/freerdp
parentdev-libs/gmp: re-add pdf (diff)
downloadgentoo-a998d5281b750cc84c8d411d186a1d3fbebaf6a5.tar.gz
gentoo-a998d5281b750cc84c8d411d186a1d3fbebaf6a5.tar.bz2
gentoo-a998d5281b750cc84c8d411d186a1d3fbebaf6a5.zip
net-misc/freerdp: Backport gstreamer build fix
Bug: https://bugs.gentoo.org/564486 Package-Manager: portage-2.2.23_p18
Diffstat (limited to 'net-misc/freerdp')
-rw-r--r--net-misc/freerdp/files/1.2.1-gstreamer.patch71
-rw-r--r--net-misc/freerdp/freerdp-1.2.1_pre20150326-r1.ebuild6
2 files changed, 76 insertions, 1 deletions
diff --git a/net-misc/freerdp/files/1.2.1-gstreamer.patch b/net-misc/freerdp/files/1.2.1-gstreamer.patch
new file mode 100644
index 000000000000..cafe9702210a
--- /dev/null
+++ b/net-misc/freerdp/files/1.2.1-gstreamer.patch
@@ -0,0 +1,71 @@
+From bea27fd919b64ee8d97996409e279e1e83d13594 Mon Sep 17 00:00:00 2001
+From: Jean-Louis Dupond <jean-louis@dupond.be>
+Date: Sun, 4 Oct 2015 18:17:33 +0200
+Subject: [PATCH] FindGStreamer_1_0: fix build failure for new gstreamer
+ versions
+
+---
+ cmake/FindGStreamer_1_0.cmake | 30 +++++++++++++++---------------
+ 1 file changed, 15 insertions(+), 15 deletions(-)
+
+diff --git a/cmake/FindGStreamer_1_0.cmake b/cmake/FindGStreamer_1_0.cmake
+index f7bf990..3aa8fc6 100644
+--- a/cmake/FindGStreamer_1_0.cmake
++++ b/cmake/FindGStreamer_1_0.cmake
+@@ -53,17 +53,17 @@ set(GSTREAMER_1_0_MINIMUM_VERSION 1.0.5)
+ # Helper macro to find a Gstreamer plugin (or Gstreamer itself)
+ # _component_prefix is prepended to the _INCLUDE_DIRS and _LIBRARIES variables (eg. "GSTREAMER_1_0_AUDIO")
+ # _pkgconfig_name is the component's pkg-config name (eg. "gstreamer-1.0", or "gstreamer-video-1.0").
+-# _header is the component's header, relative to the gstreamer-1.0 directory (eg. "gst/gst.h").
+ # _library is the component's library name (eg. "gstreamer-1.0" or "gstvideo-1.0")
+-macro(FIND_GSTREAMER_COMPONENT _component_prefix _pkgconfig_name _header _library)
++macro(FIND_GSTREAMER_COMPONENT _component_prefix _pkgconfig_name _library)
+ # FIXME: The QUIET keyword can be used once we require CMake 2.8.2.
+- pkg_check_modules(PC_${_component_prefix} ${_pkgconfig_name})
+
+- find_path(${_component_prefix}_INCLUDE_DIRS
+- NAMES ${_header}
+- HINTS ${PC_${_component_prefix}_INCLUDE_DIRS} ${PC_${_component_prefix}_INCLUDEDIR}
+- PATH_SUFFIXES gstreamer-1.0
+- )
++ string(REGEX MATCH "(.*)>=(.*)" _dummy "${_pkgconfig_name}")
++ if ("${CMAKE_MATCH_2}" STREQUAL "")
++ pkg_check_modules(PC_${_component_prefix} "${_pkgconfig_name} >= ${GStreamer_FIND_VERSION}")
++ else ()
++ pkg_check_modules(PC_${_component_prefix} ${_pkgconfig_name})
++ endif ()
++ set(${_component_prefix}_INCLUDE_DIRS ${PC_${_component_prefix}_INCLUDE_DIRS})
+
+ find_library(${_component_prefix}_LIBRARIES
+ NAMES ${_library} gstreamer_android
+@@ -78,8 +78,8 @@ endmacro()
+ # 1.1. Find headers and libraries
+ set(GLIB_ROOT_DIR ${GSTREAMER_1_0_ROOT_DIR})
+ find_package(Glib REQUIRED)
+-FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0 gstreamer-1.0 gst/gst.h gstreamer-1.0)
+-FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_BASE gstreamer-base-1.0 gst/gst.h gstbase-1.0)
++FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0 gstreamer-1.0 gstreamer-1.0)
++FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_BASE gstreamer-base-1.0 gstbase-1.0)
+
+ # 1.2. Check Gstreamer version
+ if (GSTREAMER_1_0_INCLUDE_DIRS)
+@@ -110,11 +110,11 @@ endif ()
+ # 2. Find Gstreamer plugins
+ # -------------------------
+
+-FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_APP gstreamer-app-1.0 gst/app/gstappsink.h gstapp-1.0)
+-FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_AUDIO gstreamer-audio-1.0 gst/audio/audio.h gstaudio-1.0)
+-FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_FFT gstreamer-fft-1.0 gst/fft/gstfft.h gstfft-1.0)
+-FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_PBUTILS gstreamer-pbutils-1.0 gst/pbutils/pbutils.h gstpbutils-1.0)
+-FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_VIDEO gstreamer-video-1.0 gst/video/video.h gstvideo-1.0)
++FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_APP gstreamer-app-1.0 gstapp-1.0)
++FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_AUDIO gstreamer-audio-1.0 gstaudio-1.0)
++FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_FFT gstreamer-fft-1.0 gstfft-1.0)
++FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_PBUTILS gstreamer-pbutils-1.0 gstpbutils-1.0)
++FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_VIDEO gstreamer-video-1.0 gstvideo-1.0)
+
+ # ------------------------------------------------
+ # 3. Process the COMPONENTS passed to FIND_PACKAGE
+--
+2.6.3
+
diff --git a/net-misc/freerdp/freerdp-1.2.1_pre20150326-r1.ebuild b/net-misc/freerdp/freerdp-1.2.1_pre20150326-r1.ebuild
index 0ea2dafab555..e914037665a7 100644
--- a/net-misc/freerdp/freerdp-1.2.1_pre20150326-r1.ebuild
+++ b/net-misc/freerdp/freerdp-1.2.1_pre20150326-r1.ebuild
@@ -81,7 +81,11 @@ DEPEND="${RDEPEND}
DOCS=( README )
-PATCHES=( "${FILESDIR}/freerdp-armfp.patch" "${FILESDIR}/freerdp-ffmpeg29.patch" )
+PATCHES=(
+ "${FILESDIR}/freerdp-armfp.patch"
+ "${FILESDIR}/freerdp-ffmpeg29.patch"
+ "${FILESDIR}/1.2.1-gstreamer.patch"
+)
src_configure() {
local mycmakeargs=(