summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2020-11-11 17:00:03 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-11 19:27:58 +0200
commit19ee9c8d9be902c07b0dba660d259df8d5ab4ef5 (patch)
treeda08ac9aa5df6617d7211010af1d26d7684533bd /net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild
parentgui-wm/sway: bump wlroots for future copies (diff)
downloadgentoo-19ee9c8d9be902c07b0dba660d259df8d5ab4ef5.tar.gz
gentoo-19ee9c8d9be902c07b0dba660d259df8d5ab4ef5.tar.bz2
gentoo-19ee9c8d9be902c07b0dba660d259df8d5ab4ef5.zip
net-misc/gallery-dl: add required python use
Closes: https://bugs.gentoo.org/754030 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/18223 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild')
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild b/net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild
new file mode 100644
index 000000000000..e676807a0eaf
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7,8})
+PYTHON_REQ_USE="sqlite,ssl,xml"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# tests require network access
+RESTRICT="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_compile() {
+ emake data/completion/gallery-dl
+ emake data/completion/_gallery-dl
+ emake man
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ elog ""
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}