summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2020-12-12 23:31:20 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-13 12:44:20 +0200
commit2f3bef79c2b8ac69680431eb8b36b8584ba8eb06 (patch)
tree371970926fd4a09b193f0eca27b3fc1eb241e69c /net-misc/gallery-dl/gallery-dl-1.16.0.ebuild
parentdev-python/pipenv: bump to version 2020.11.15 (diff)
downloadgentoo-2f3bef79c2b8ac69680431eb8b36b8584ba8eb06.tar.gz
gentoo-2f3bef79c2b8ac69680431eb8b36b8584ba8eb06.tar.bz2
gentoo-2f3bef79c2b8ac69680431eb8b36b8584ba8eb06.zip
net-misc/gallery-dl: bump to 1.16.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/18629 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/gallery-dl/gallery-dl-1.16.0.ebuild')
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.16.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/gallery-dl-1.16.0.ebuild b/net-misc/gallery-dl/gallery-dl-1.16.0.ebuild
new file mode 100644
index 000000000000..458d0edf5edc
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.16.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+PYTHON_REQ_USE="sqlite,ssl,xml"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# tests require network access
+RESTRICT="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_compile() {
+ emake data/completion/gallery-dl
+ emake data/completion/_gallery-dl
+ emake man
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ elog ""
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}