summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-10 17:50:18 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-10 18:08:56 +0100
commit7363acd88db1b0761ee217ee1087d8525a14875e (patch)
tree6b0c1f14cc471f1b366d04e4b939ee045a21aba5 /net-misc/gallery-dl
parentsys-apps/syd: add 3.8.7, drop 3.8.5 (diff)
downloadgentoo-7363acd88db1b0761ee217ee1087d8525a14875e.tar.gz
gentoo-7363acd88db1b0761ee217ee1087d8525a14875e.tar.bz2
gentoo-7363acd88db1b0761ee217ee1087d8525a14875e.zip
net-misc/gallery-dl: bump to 1.26.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/gallery-dl')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.26.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 9a19523e60cd..3da576fe34a4 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,2 +1,3 @@
DIST gallery-dl-1.26.2.gh.tar.gz 607389 BLAKE2B 9bacfa4ba4019dbd8abd87ad868b1f6d2c56eab165633a07ba99c569962f26df6d82c96ef12c0c033792ece2084e4f5b7a2121483d51d765b828d4997780edc1 SHA512 08f0caa07f1e3fddf003658e9261e711b2a5fc0049447f36794c441f37ba01b74cc091f90378d5a649196ceba487d5dff541dbfcd86ca8c1b0551a972dc1f848
DIST gallery-dl-1.26.3.gh.tar.gz 621229 BLAKE2B d85be6e8f3e21d5f8e18bcf70fb51f46d5672d48115bf88fb5fa3316b6e8cddca8c8c6f540f3b1529e6607d746aba98097aa95f692e98effa4e51ba4578d16aa SHA512 43891d40de26527b7195c064fda6c8303461c5e4107b0482ca535f06b8fe923513acc212bd75b4d8d82fa12e19ef214e1ee395ced1525eceda7a433d3d05fef3
+DIST gallery-dl-1.26.4.gh.tar.gz 626072 BLAKE2B 84711edcb8bd78732a0a065c7c1df5c8ff159cd5c494dd95bba4823aedb38e9435876335b7aa665270644a5d608c154d2ab5057d8c86d6f5cbc73073b819f017 SHA512 d39a8635949150a41b6c86b449ac2c42a96ac15b36555d9ea09071bf91984e64868331bfe6cb1de17ba90c509c3003a01fe5c80918d02176cae6cd6eef826a01
diff --git a/net-misc/gallery-dl/gallery-dl-1.26.4.ebuild b/net-misc/gallery-dl/gallery-dl-1.26.4.ebuild
new file mode 100644
index 000000000000..b3da2a9c870f
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.26.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# Tests require network access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}