summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/hsc/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/hsc/files')
-rw-r--r--net-misc/hsc/files/hsc-1.0b-cflags.patch45
-rw-r--r--net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch12
-rw-r--r--net-misc/hsc/files/hsc-1.0b-nostrip.patch18
-rw-r--r--net-misc/hsc/files/hsc-1.0b-parmake.patch13
4 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/hsc/files/hsc-1.0b-cflags.patch b/net-misc/hsc/files/hsc-1.0b-cflags.patch
new file mode 100644
index 000000000000..1459d5ad049a
--- /dev/null
+++ b/net-misc/hsc/files/hsc-1.0b-cflags.patch
@@ -0,0 +1,45 @@
+Index: hsc-1.0/configure.in
+===================================================================
+--- hsc-1.0.orig/configure.in
++++ hsc-1.0/configure.in
+@@ -46,12 +46,12 @@ case $host in
+ ;;
+ esac
+ echo "Configuring for $SYSTEM"
+-CFLAGS="-Wall -pedantic"
++CFLAGS="$CFLAGS -Wall -pedantic"
+
+ AC_ARG_ENABLE(debug,
+ AS_HELP_STRING([--enable-debug],[Compile programs with GDB support and debugging output]),
+ [CFLAGS="$CFLAGS -ggdb -g3 -DDEBUG"; REGEXDEBUG="regex/printchar.o"],
+- CFLAGS="$CFLAGS -fomit-frame-pointer -Os")
++ CFLAGS="$CFLAGS")
+ AC_ARG_ENABLE(efence,
+ AS_HELP_STRING([--enable-efence],[Link with efence library for memory debugging]),
+ CFLAGS="$CFLAGS -lefence")
+Index: hsc-1.0/src/regex/Makefile.in
+===================================================================
+--- hsc-1.0.orig/src/regex/Makefile.in
++++ hsc-1.0/src/regex/Makefile.in
+@@ -29,7 +29,7 @@ version = 0.12
+ CPPFLAGS =
+
+ # Likewise, you can override CFLAGS to optimize, use -Wall, etc.
+-CFLAGS = -g
++#CFLAGS = -g
+
+ # Ditto for LDFLAGS and LOADLIBES.
+ LDFLAGS =
+Index: hsc-1.0/src/Makefile.in
+===================================================================
+--- hsc-1.0.orig/src/Makefile.in
++++ hsc-1.0/src/Makefile.in
+@@ -27,7 +27,7 @@ DATADIR=@datadir@
+
+ CFLAGS = @CFLAGS@ -D@SYSTEM@ -I.
+ COMP = @CC@ -o $@ $(CFLAGS)
+-LINK = @CC@ -o $@ $(CFLAGS)
++LINK = @CC@ -o $@ $(CFLAGS) $(LDFLAGS)
+ LINKLIBS= @LINKLIBS@
+ MOVE = mv
+ COPY = cp
diff --git a/net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch b/net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch
new file mode 100644
index 000000000000..5c10efc0f9a2
--- /dev/null
+++ b/net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch
@@ -0,0 +1,12 @@
+diff -ur hsc-1.0.orig/src/hsclib/css.c hsc-1.0/src/hsclib/css.c
+--- hsc-1.0.orig/src/hsclib/css.c 2006-04-03 17:18:37.000000000 +0300
++++ hsc-1.0/src/hsclib/css.c 2009-08-09 20:19:51.000000000 +0300
+@@ -129,7 +129,7 @@
+ #ifdef isblank
+ #undef isblank
+ #endif
+-static int isblank(int c)
++int isblank(int c)
+ {
+ return ((c == ' ') || (c == '\t'));
+ }
diff --git a/net-misc/hsc/files/hsc-1.0b-nostrip.patch b/net-misc/hsc/files/hsc-1.0b-nostrip.patch
new file mode 100644
index 000000000000..af4cc947d8fd
--- /dev/null
+++ b/net-misc/hsc/files/hsc-1.0b-nostrip.patch
@@ -0,0 +1,18 @@
+Index: hsc-1.0/src/Makefile.in
+===================================================================
+--- hsc-1.0.orig/src/Makefile.in
++++ hsc-1.0/src/Makefile.in
+@@ -87,10 +87,9 @@ rex:
+ # installation
+ #--------------------------------------------------------------------
+ install : all
+- strip $(EXE_ALL)
+- $(INSTALL) -Ds hsc/hsc $(BINDIR)/hsc
+- $(INSTALL) -Ds hsctools/hscdepp $(BINDIR)/hscdepp
+- $(INSTALL) -Ds hsctools/hscpitt $(BINDIR)/hscpitt
++ $(INSTALL) -D hsc/hsc $(BINDIR)/hsc
++ $(INSTALL) -D hsctools/hscdepp $(BINDIR)/hscdepp
++ $(INSTALL) -D hsctools/hscpitt $(BINDIR)/hscpitt
+
+ #--------------------------------------------------------------------
+ # cleanup - remove all objects and executables
diff --git a/net-misc/hsc/files/hsc-1.0b-parmake.patch b/net-misc/hsc/files/hsc-1.0b-parmake.patch
new file mode 100644
index 000000000000..8c93d32f4888
--- /dev/null
+++ b/net-misc/hsc/files/hsc-1.0b-parmake.patch
@@ -0,0 +1,13 @@
+Index: hsc-1.0/Makefile.in
+===================================================================
+--- hsc-1.0.orig/Makefile.in
++++ hsc-1.0/Makefile.in
+@@ -30,7 +30,7 @@ all: hsc docs
+
+ hsc:
+ make -C src
+-docs:
++docs: hsc
+ PATH="$(shell pwd)/src/hsc:$(PATH)" HSCEXTRAOPTS="IGNORE=21" make -C docs-source
+
+ install: