summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2018-11-08 19:33:07 +0100
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-09 20:05:18 -0800
commit47be16981378a8a7e3500476c610c342316f3097 (patch)
tree01e691f229b28ad8b333f62263569dd8a0ea38ed /net-misc/httpie
parentdev-python/cryptography: Version bump to 2.3.1 (bug #667678) (diff)
downloadgentoo-47be16981378a8a7e3500476c610c342316f3097.tar.gz
gentoo-47be16981378a8a7e3500476c610c342316f3097.tar.bz2
gentoo-47be16981378a8a7e3500476c610c342316f3097.zip
net-misc/httpie: ebuild for upstream release 1.0.0
This ebuild wraps HTTPie 1.0.0 (released 2018-11-02). Closes: https://github.com/gentoo/gentoo/pull/10366 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-misc/httpie')
-rw-r--r--net-misc/httpie/Manifest1
-rw-r--r--net-misc/httpie/httpie-1.0.0.ebuild28
-rw-r--r--net-misc/httpie/metadata.xml23
3 files changed, 45 insertions, 7 deletions
diff --git a/net-misc/httpie/Manifest b/net-misc/httpie/Manifest
index f6211dc5caf5..8f86610e5388 100644
--- a/net-misc/httpie/Manifest
+++ b/net-misc/httpie/Manifest
@@ -2,3 +2,4 @@ DIST httpie-0.9.2.tar.gz 73153 BLAKE2B 53ca1f5dd683d68ff6416a297bb45a2827f516a64
DIST httpie-0.9.3.tar.gz 73693 BLAKE2B f188a7fe5f63b39022d2a67e8f9dc2582ce8e8d4860b880b2e26403149361b999294bf0e55b41bf1773e73c0ffe81abd01c6c1e2ddaf755dfc31ab7e463b8516 SHA512 a98aa19ddcc5223133f1081ce22457d21b838b5779788a08d0b65ea80f903ab577a55e0c73b3656486eec08c3c0910d3e987aed0f117c5f9b3e005c6001000cc
DIST httpie-0.9.4.tar.gz 79889 BLAKE2B 13053cb3389a03ecbd90caba85801772cba9f09a03f759d526256fc0195a31824408a02b004d3af50a1fbcaca7c02128b438ce341464825a08e4dbd5177ddf99 SHA512 eea4e0fce334d12f9438d89f87d119bc569f8042d95c87f6898b9110030674f49361bf8e119d815330aa117479557766d614510d81c42c9c3a6803c769f38b26
DIST httpie-0.9.9.tar.gz 85006 BLAKE2B c5412348b3add127a5d5dfc04fdc13a47f82ec65634eedefb55a0cf1ce182a49f81a3a68c0cbb5e8c90b53efb165c89b7444d23328e545bdbf92d69d1de9c921 SHA512 e9adb1ecf9a25b57c634f35199bf1f8fbe4136179c0ba0d6032a41ae786da9344f54436f91d89e624c154bdca325f94c637364a934fc2d5742b83056434f7e4c
+DIST httpie-1.0.0.tar.gz 268982 BLAKE2B 36ae23876c995f450ac4d814a56a79db7aee175f3b6b060bf08049cd2ea5ec5000c91bf49a12eae8a2dff2c91e5d5200d3febc4cdd50d0488db35eb96777ed14 SHA512 9a68746636e367d1131069787f4a4a199b6434b828fe58fecef70e810c1d63c662c790fc45fd955a390113920a29d0116cf29d1167d638debe6b9419a4ae2d48
diff --git a/net-misc/httpie/httpie-1.0.0.ebuild b/net-misc/httpie/httpie-1.0.0.ebuild
new file mode 100644
index 000000000000..64a41d2bfb6d
--- /dev/null
+++ b/net-misc/httpie/httpie-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Modern command line HTTP client"
+HOMEPAGE="https://httpie.org/ https://pypi.org/project/httpie/"
+SRC_URI="https://github.com/jakubroztocil/httpie/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ newbashcomp extras/httpie-completion.bash http
+ insinto /usr/share/fish/vendor_completions.d
+ newins extras/httpie-completion.fish http.fish
+ distutils-r1_python_install_all
+}
diff --git a/net-misc/httpie/metadata.xml b/net-misc/httpie/metadata.xml
index 744caf5b31d1..a054286ef778 100644
--- a/net-misc/httpie/metadata.xml
+++ b/net-misc/httpie/metadata.xml
@@ -1,16 +1,25 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!--maintainer-needed-->
+ <maintainer type="person">
+ <email>gentoo@seichter.de</email>
+ <name>Ralph Seichter</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<longdescription lang="en">
- HTTPie is a command line HTTP client. Its goal is to make CLI
- interaction with web services as human-friendly as possible. It
- provides a simple http command that allows for sending arbitrary HTTP
- requests using a simple and natural syntax, and displays colorized
- responses. HTTPie can be used for testing, debugging, and generally
- interacting with HTTP servers.
+ HTTPie (pronounced aitch-tee-tee-pie) is a command line HTTP
+ client. Its goal is to make CLI interaction with web services as
+ human-friendly as possible. It provides a simple http command
+ that allows for sending arbitrary HTTP requests using a simple
+ and natural syntax, and displays colorized output. HTTPie can be
+ used for testing, debugging, and generally interacting with HTTP
+ servers.
</longdescription>
<upstream>
+ <remote-id type="github">jakubroztocil/httpie</remote-id>
<remote-id type="pypi">httpie</remote-id>
</upstream>
</pkgmetadata>