summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2020-04-18 23:18:38 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-21 11:17:20 +0300
commitd26bda5f5f96d4b95cd194ac276a098eff42b690 (patch)
treee4aaccdaa77005c547c6a5d0ecafec00081d233c /net-misc/httpie
parentnet-im/psi: added cmake flag to compile with detailed version (diff)
downloadgentoo-d26bda5f5f96d4b95cd194ac276a098eff42b690.tar.gz
gentoo-d26bda5f5f96d4b95cd194ac276a098eff42b690.tar.bz2
gentoo-d26bda5f5f96d4b95cd194ac276a098eff42b690.zip
net-misc/httpie: Bump to version 2.1.0
This ebuild adds support for Python 3.8. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/15403 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/httpie')
-rw-r--r--net-misc/httpie/Manifest1
-rw-r--r--net-misc/httpie/httpie-2.1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/httpie/Manifest b/net-misc/httpie/Manifest
index 0ad06b6c9184..ff3b4039a866 100644
--- a/net-misc/httpie/Manifest
+++ b/net-misc/httpie/Manifest
@@ -1,2 +1,3 @@
DIST httpie-1.0.3.tar.gz 1745537 BLAKE2B 82279804bf10c1882a163f7b361917c9013a5d4ec9ace934f4d89a8c42d18575863cec57768bb4ccfed3b9913a7f2cba593f398a36f87d045a68f21c7237e381 SHA512 80e540dcb92a55fb8b3c5dd56f380cb1795e4296827591853070a5b775c1f87cd881758d9dd0bdfeff383d06ce8ffafe68ec0269e3d269473e528952a769ecb7
DIST httpie-2.0.0.tar.gz 1752529 BLAKE2B 212e7a142f3efdf1bf238d6eb7e472579a8a8248950caf19ec584eba4f903de09b08433805105a61714046857d32b662f54cde927d20db2a2a1ab81bc99bc753 SHA512 ddac5206107241c9fdc2d2697a31fc7a123c3a01c2ccbd0aad8d52e1472f093b201e422522972cce992bfb2fc7d32ffc6380d457112c83ab643008086f9a7f2d
+DIST httpie-2.1.0.tar.gz 1754801 BLAKE2B dabb6a1ce0cc4ecebbc7e933ed3084d7b75e0fac1fbf6968f41d37ee95cef684ee3603ddb5361e072328d13c9c98332b23bfdd0454da3399038307b124ea2e98 SHA512 39d56c9b9aad4871ce439a235377a930ad7c78b833f9bad568142efc9fd8af9123ac931e434c6ddb7fa6e0deb0acf8f5fd1ddf79f3b7a65467267cbf4629555b
diff --git a/net-misc/httpie/httpie-2.1.0.ebuild b/net-misc/httpie/httpie-2.1.0.ebuild
new file mode 100644
index 000000000000..e3773e796fbe
--- /dev/null
+++ b/net-misc/httpie/httpie-2.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Modern command line HTTP client"
+HOMEPAGE="https://httpie.org/ https://pypi.org/project/httpie/"
+SRC_URI="https://github.com/jakubroztocil/httpie/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]"
+DEPEND="test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ newbashcomp extras/httpie-completion.bash http
+ insinto /usr/share/fish/vendor_completions.d
+ newins extras/httpie-completion.fish http.fish
+ distutils-r1_python_install_all
+}