summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-18 13:10:00 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-18 13:10:19 +0200
commitd5af0ceadc4a82de135b5083fb1e028809e86ae0 (patch)
treedc3d07b4347cba9ba36f07531a8612a2d5b5b6c8 /net-misc/iperf
parentprofiles/updates: Remove stale entry (diff)
downloadgentoo-d5af0ceadc4a82de135b5083fb1e028809e86ae0.tar.gz
gentoo-d5af0ceadc4a82de135b5083fb1e028809e86ae0.tar.bz2
gentoo-d5af0ceadc4a82de135b5083fb1e028809e86ae0.zip
net-misc/iperf: Set AR
Package-Manager: Portage-3.0.3, Repoman-3.0.0 Closes: https://bugs.gentoo.org/737832 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/iperf')
-rw-r--r--net-misc/iperf/iperf-2.0.14a.ebuild7
-rw-r--r--net-misc/iperf/iperf-2.99999.99999.ebuild8
2 files changed, 12 insertions, 3 deletions
diff --git a/net-misc/iperf/iperf-2.0.14a.ebuild b/net-misc/iperf/iperf-2.0.14a.ebuild
index 25750ac91672..15f7dc5179ff 100644
--- a/net-misc/iperf/iperf-2.0.14a.ebuild
+++ b/net-misc/iperf/iperf-2.0.14a.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
DESCRIPTION="Tool to measure IP bandwidth using UDP or TCP"
HOMEPAGE="https://sourceforge.net/projects/iperf2/"
@@ -26,6 +27,10 @@ src_configure() {
$(use_enable threads)
}
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
default
dodoc doc/*
diff --git a/net-misc/iperf/iperf-2.99999.99999.ebuild b/net-misc/iperf/iperf-2.99999.99999.ebuild
index 0e887f4a4e2d..5d1c5b42d4a4 100644
--- a/net-misc/iperf/iperf-2.99999.99999.ebuild
+++ b/net-misc/iperf/iperf-2.99999.99999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3
+inherit git-r3 toolchain-funcs
DESCRIPTION="Tool to measure IP bandwidth using UDP or TCP"
HOMEPAGE="https://sourceforge.net/projects/iperf2/"
@@ -25,6 +25,10 @@ src_configure() {
$(use_enable threads)
}
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
default
dodoc doc/*