summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2016-01-07 15:52:55 +0000
committerTony Vroon <chainsaw@gentoo.org>2016-01-07 15:53:04 +0000
commit5af8c26412015094579971cae142856e53e59ad8 (patch)
treead5806b86e8cd9588dfeb89397446357c867dc99 /net-misc/kea/kea-1.0.0.ebuild
parentdev-java/icedtea: Patch against icedtea bug #2781 (diff)
downloadgentoo-5af8c26412015094579971cae142856e53e59ad8.tar.gz
gentoo-5af8c26412015094579971cae142856e53e59ad8.tar.bz2
gentoo-5af8c26412015094579971cae142856e53e59ad8.zip
net-misc/kea: Adding 1.0.0 to tree.
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/kea/kea-1.0.0.ebuild')
-rw-r--r--net-misc/kea/kea-1.0.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/kea/kea-1.0.0.ebuild b/net-misc/kea/kea-1.0.0.ebuild
new file mode 100644
index 000000000000..48192d85293f
--- /dev/null
+++ b/net-misc/kea/kea-1.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs user
+
+MY_PV="${PV//_alpha/a}"
+MY_PV="${MY_PV//_beta/b}"
+MY_PV="${MY_PV//_rc/rc}"
+MY_PV="${MY_PV//_p/-P}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="High-performance production grade DHCPv4 & DHCPv6 server"
+HOMEPAGE="http://www.isc.org/kea/"
+SRC_URI="ftp://ftp.isc.org/isc/kea/${MY_P}.tar.gz
+ ftp://ftp.isc.org/isc/kea/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="ISC BSD SSLeay GPL-2" # GPL-2 only for init script
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ipv6 kernel_linux ldap libressl selinux ssl"
+
+DEPEND="
+ dev-cpp/gtest
+ dev-libs/boost
+ dev-libs/botan
+ dev-libs/log4cplus
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Brand the version with Gentoo
+ sed -i \
+ -e "/VERSION=/s:'$: Gentoo-${PR}':" \
+ configure || die
+}
+
+src_configure() {
+ econf \
+ --disable-install-configurations \
+ --disable-static \
+ --without-werror
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_preinst() {
+ enewgroup dhcp
+ enewuser dhcp -1 -1 /var/lib/dhcp dhcp
+}