summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/mediatomb/mediatomb-0.12.1-r8.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/mediatomb/mediatomb-0.12.1-r8.ebuild')
-rw-r--r--net-misc/mediatomb/mediatomb-0.12.1-r8.ebuild157
1 files changed, 157 insertions, 0 deletions
diff --git a/net-misc/mediatomb/mediatomb-0.12.1-r8.ebuild b/net-misc/mediatomb/mediatomb-0.12.1-r8.ebuild
new file mode 100644
index 000000000000..e0d46477e307
--- /dev/null
+++ b/net-misc/mediatomb/mediatomb-0.12.1-r8.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils linux-info user
+
+DEB_VER="5"
+DESCRIPTION="MediaTomb is an open source UPnP MediaServer"
+HOMEPAGE="http://www.mediatomb.cc/"
+
+SRC_URI="mirror://sourceforge/mediatomb/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_VER}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+
+IUSE="curl debug +exif +ffmpeg flac id3tag +inotify +javascript lastfm
+ libextractor +magic +mp4 mysql +sqlite +taglib thumbnail +zlib"
+REQUIRED_USE="
+ || ( mysql sqlite )
+ taglib? ( !id3tag )
+ id3tag? ( !taglib )
+ thumbnail? ( ffmpeg !libextractor )
+ ffmpeg? ( !libextractor )
+ libextractor? ( !ffmpeg !thumbnail )
+"
+
+DEPEND="mysql? ( virtual/mysql )
+ dev-libs/expat
+ id3tag? ( media-libs/id3lib )
+ javascript? ( >=dev-lang/spidermonkey-1.8.5:0 )
+ taglib? ( media-libs/taglib )
+ sqlite? ( >=dev-db/sqlite-3 )
+ lastfm? ( >=media-libs/lastfmlib-0.4 )
+ exif? ( media-libs/libexif )
+ libextractor? ( media-libs/libextractor )
+ mp4? ( >=media-libs/libmp4v2-1.9.1_p479:0 )
+ ffmpeg? ( virtual/ffmpeg )
+ flac? ( media-libs/flac )
+ thumbnail? ( media-video/ffmpegthumbnailer[jpeg] )
+ curl? ( net-misc/curl net-misc/youtube-dl )
+ magic? ( sys-apps/file )
+ sys-apps/util-linux
+ zlib? ( sys-libs/zlib )
+ virtual/libiconv
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~INOTIFY_USER"
+
+pkg_setup() {
+ enewgroup mediatomb
+ enewuser mediatomb -1 -1 /dev/null mediatomb
+}
+
+src_prepare() {
+ # Apply Debians patchset
+ local p dd="${WORKDIR}"/debian/patches
+ sed -i -r '/^[-+]{3} /s:[.][.]/::' "${dd}"/* || die
+ # We use our version as it seems to be more complete.
+ sed -i '/^0010_fix_libmp4v2_build.patch/d' "${dd}"/series || die
+ for p in $(<"${dd}"/series) ; do
+ epatch "${dd}"/${p}
+ done
+
+ # libmp4v2 API breakage #410235
+ epatch "${FILESDIR}"/${P}-libmp4v2.patch
+
+ # Use system libuuid #270830
+ epatch "${FILESDIR}"/${P}-system-uuid.patch
+
+ # Support spidermonkey-187 #423991 #482392
+ if has_version "~dev-lang/spidermonkey-1.8.7" ; then
+ epatch "${FILESDIR}"/${P}-mozjs187.patch
+ fi
+
+ # Support libextractor-0.6.0 #435394
+ epatch "${FILESDIR}"/${P}-libextractor.patch
+
+ # Fix inotify and hard links
+ epatch "${FILESDIR}"/${P}-inotify-hard-links.patch
+
+ # Add support for caching thumbnails
+ epatch "${FILESDIR}"/${P}-thumb-cache.patch
+ epatch "${FILESDIR}"/${P}-thumbnail-locking.patch
+
+ # Respect AR #464710
+ epatch "${FILESDIR}"/${P}-system-ar.patch
+
+ # Add flac metadata support #494398
+ epatch "${FILESDIR}"/${P}-flac-metadata.patch
+
+ # Work around broken youtube support by using youtube-dl #467110
+ epatch "${FILESDIR}"/${P}-youtube-dl.patch
+
+ epatch_user
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable curl) \
+ $(use_enable curl youtube) \
+ $(use_enable debug tombdebug) \
+ $(use_enable exif libexif) \
+ $(use_enable ffmpeg) \
+ $(use_enable flac FLAC) \
+ $(use_enable id3tag id3lib) \
+ $(use_enable inotify) \
+ $(use_enable javascript libjs) \
+ $(use_enable lastfm lastfmlib) \
+ $(use_enable libextractor) \
+ $(use_enable magic libmagic) \
+ $(use_enable mp4 libmp4v2) \
+ $(use_enable mysql) \
+ $(use_enable sqlite sqlite3) \
+ $(use_enable taglib) \
+ $(use_enable thumbnail ffmpegthumbnailer) \
+ $(use_enable zlib) \
+ --enable-external-transcoding \
+ --enable-protocolinfo-extension
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}-0.12.1.initd ${PN}
+ use mysql || sed -i -e "/use mysql/d" "${ED}"/etc/init.d/${PN}
+ newconfd "${FILESDIR}"/${PN}-0.12.0.confd ${PN}
+
+ insinto /etc/mediatomb
+ newins "${FILESDIR}/${PN}-0.12.0.config" config.xml
+ fperms 0600 /etc/mediatomb/config.xml
+ fowners mediatomb:mediatomb /etc/mediatomb/config.xml
+
+ keepdir /var/lib/mediatomb
+ fowners mediatomb:mediatomb /var/lib/mediatomb
+}
+
+pkg_postinst() {
+ if use mysql ; then
+ elog "MediaTomb has been built with MySQL support and needs"
+ elog "to be configured before being started."
+ elog "For more information, please consult the MediaTomb"
+ elog "documentation: http://mediatomb.cc/pages/documentation"
+ elog
+ fi
+
+ elog "To configure MediaTomb edit:"
+ elog "/etc/mediatomb/config.xml"
+ elog
+ elog "The MediaTomb web interface can be reached at (after the service is started):"
+ elog "http://localhost:49152/"
+}