summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/mindterm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/mindterm')
-rw-r--r--net-misc/mindterm/Manifest1
-rw-r--r--net-misc/mindterm/files/mindterm-3.2-missingclasses.patch19
-rw-r--r--net-misc/mindterm/metadata.xml5
-rw-r--r--net-misc/mindterm/mindterm-3.4.ebuild56
4 files changed, 81 insertions, 0 deletions
diff --git a/net-misc/mindterm/Manifest b/net-misc/mindterm/Manifest
new file mode 100644
index 000000000000..e3b3a603acac
--- /dev/null
+++ b/net-misc/mindterm/Manifest
@@ -0,0 +1 @@
+DIST mindterm_3.4-src.zip 1224973 SHA256 46d19b5037db3aa687f33bcda36590385b555a3abae98deb32be0ffd2ec70183
diff --git a/net-misc/mindterm/files/mindterm-3.2-missingclasses.patch b/net-misc/mindterm/files/mindterm-3.2-missingclasses.patch
new file mode 100644
index 000000000000..b231d64ad9fa
--- /dev/null
+++ b/net-misc/mindterm/files/mindterm-3.2-missingclasses.patch
@@ -0,0 +1,19 @@
+diff -Nur mindterm_3.2/filesets.xml mindterm_3.2_patched/filesets.xml
+--- mindterm_3.2/filesets.xml 2007-10-02 16:09:12.000000000 +0300
++++ mindterm_3.2_patched/filesets.xml 2009-02-01 10:56:02.000000000 +0200
+@@ -145,6 +145,7 @@
+ com/mindbright/security/publickey/DSAPrivateKey.class
+ com/mindbright/security/publickey/DSAPublicKey.class
+ com/mindbright/security/publickey/DSAWithSHA1.class
++ com/mindbright/security/publickey/DSAWithSHA1$DSASIG.class
+ com/mindbright/security/publickey/DiffieHellman.class
+ com/mindbright/security/publickey/ModPGroups.class
+ com/mindbright/security/publickey/RawDSAWithSHA1.class
+@@ -565,6 +566,7 @@
+ com/mindbright/terminal/tandem6530/ProtectBlockMode.class
+ com/mindbright/terminal/tandem6530/ActionHandler.class
+ com/mindbright/terminal/tandem6530/Parser.class
++ com/mindbright/terminal/tandem6530/Parser*.class
+ com/mindbright/terminal/tandem6530/Parser$Collector.class
+ com/mindbright/terminal/tandem6530/ParseException.class
+ com/mindbright/terminal/tandem6530/BadColorException.class
diff --git a/net-misc/mindterm/metadata.xml b/net-misc/mindterm/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/net-misc/mindterm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
diff --git a/net-misc/mindterm/mindterm-3.4.ebuild b/net-misc/mindterm/mindterm-3.4.ebuild
new file mode 100644
index 000000000000..f6526a6f376e
--- /dev/null
+++ b/net-misc/mindterm/mindterm-3.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+WANT_ANT_TASKS="ant-nodeps"
+JAVA_PKG_IUSE="doc test examples"
+inherit eutils java-pkg-2 java-ant-2
+
+MY_P=${P/-/_}
+
+DESCRIPTION="A Java SSH Client"
+HOMEPAGE="http://www.appgate.com/products/80_MindTerm/"
+SRC_URI="http://www.appgate.com/downloads/MindTerm-${PV}/${MY_P}-src.zip"
+
+LICENSE="mindterm"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+COMMON_DEP="dev-java/jzlib:0"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S=${WORKDIR}/${MY_P}
+
+JAVA_PKG_FILTER_COMPILER="jikes"
+EANT_BUILD_TARGET="mindterm.jar lite"
+EANT_DOC_TARGET="doc"
+EANT_GENTOO_CLASSPATH="jzlib"
+JAVA_ANT_CLASSPATH_TAGS+=" javadoc"
+
+src_prepare() {
+ java-pkg-2_src_prepare
+ java-ant_rewrite-classpath
+ rm -vr com/jcraft || die "Failed to remove bundled jcraft"
+}
+
+# Don't even compile
+RESTRICT="test"
+src_test() {
+ ANT_TASKS="ant-junit ant-nodeps" eant test \
+ -Dgentoo.classpath="$(java-pkg_getjars jzlib,junit):mindterm.jar"
+}
+
+src_install() {
+ java-pkg_dojar *.jar
+
+ java-pkg_dolauncher ${PN} --main com.mindbright.application.MindTerm
+
+ dodoc README.txt RELEASE_NOTES.txt CHANGES || die
+ use doc && java-pkg_dojavadoc javadoc
+ use examples && java-pkg_doexamples "${S}/examples/"
+}