summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-02-26 02:16:48 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-02-26 02:17:43 +1100
commitc5d31b7b969837507660ca92b5b77454766916fb (patch)
tree88540ff4ac037200e91fc9c0d148a6b19e04cd61 /net-misc/netfleet
parentx11-wm/xpra: Revbump to add xpra system group (bug 572270, thanks Fabian Henz... (diff)
downloadgentoo-c5d31b7b969837507660ca92b5b77454766916fb.tar.gz
gentoo-c5d31b7b969837507660ca92b5b77454766916fb.tar.bz2
gentoo-c5d31b7b969837507660ca92b5b77454766916fb.zip
net-misc/netfleet: revision bump
* Port to EAPI 6 * Port away from qt4-r2.eclass * Add missing dependency Gentoo-bug: 575642 Package-Manager: portage-2.2.27
Diffstat (limited to 'net-misc/netfleet')
-rw-r--r--net-misc/netfleet/netfleet-0.2.1-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/netfleet/netfleet-0.2.1-r2.ebuild b/net-misc/netfleet/netfleet-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..2873910d37d8
--- /dev/null
+++ b/net-misc/netfleet/netfleet-0.2.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Qt4 cross-platform multi-threaded download utility"
+HOMEPAGE="http://qt-apps.org/content/show.php/?content=103312"
+SRC_URI="https://netfleet.googlecode.com/files/${PN}_${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}