summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 19:37:44 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-03 19:37:44 +0100
commita5fdae03af8592322e6e515d01a219c9216c9455 (patch)
tree39aaed29911dd42b8f236245e6a9c553c527c8e1 /net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild
parentnet-misc/arpd: Port to EAPI 6 (diff)
downloadgentoo-a5fdae03af8592322e6e515d01a219c9216c9455.tar.gz
gentoo-a5fdae03af8592322e6e515d01a219c9216c9455.tar.bz2
gentoo-a5fdae03af8592322e6e515d01a219c9216c9455.zip
net-misc/netkit-bootpd: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild')
-rw-r--r--net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild b/net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild
index 7ae6c8941158..cb70f0e56efd 100644
--- a/net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild
+++ b/net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
-inherit eutils toolchain-funcs
+EAPI=6
+
+inherit toolchain-funcs
MY_P=${P/netkit-}
@@ -17,20 +18,22 @@ IUSE=""
S=${WORKDIR}/${MY_P}
-src_prepare() {
- epatch "${FILESDIR}"/${P}.patch
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+src_configure() {
+ tc-export CC
}
src_compile() {
- tc-export CC
- emake linux || die
+ emake linux
}
src_install() {
- dosbin bootp{d,ef,gw,test} || die
+ dosbin bootp{d,ef,gw,test}
+ local x
for x in d ef gw test; do
- dosym bootp${x} /usr/sbin/in.bootp${x} || die
+ dosym bootp${x} /usr/sbin/in.bootp${x}
done
doman *.5 *.8