summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 19:26:36 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:26:36 -0500
commit5022f21d9d23fd2126ac38516a8eaf7024e92689 (patch)
tree970935b0e71be10ceb2d763b445a6dc154fee1fc /net-misc/netkit-timed/netkit-timed-0.17-r10.ebuild
parentnet-misc/netkit-routed: remove old version (diff)
downloadgentoo-5022f21d9d23fd2126ac38516a8eaf7024e92689.tar.gz
gentoo-5022f21d9d23fd2126ac38516a8eaf7024e92689.tar.bz2
gentoo-5022f21d9d23fd2126ac38516a8eaf7024e92689.zip
net-misc/netkit-timed: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/netkit-timed/netkit-timed-0.17-r10.ebuild')
-rw-r--r--net-misc/netkit-timed/netkit-timed-0.17-r10.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/netkit-timed/netkit-timed-0.17-r10.ebuild b/net-misc/netkit-timed/netkit-timed-0.17-r10.ebuild
new file mode 100644
index 000000000000..80ed9172b717
--- /dev/null
+++ b/net-misc/netkit-timed/netkit-timed-0.17-r10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit flag-o-matic toolchain-funcs
+
+IUSE=""
+DESCRIPTION="Netkit - timed"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
+LICENSE="BSD GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ eapply "${FILESDIR}"/0.17-CFLAG-DEF-fix.patch
+ eapply "${FILESDIR}"/0.17-timed-opt-parsing.patch
+ sed -i configure \
+ -e '/^LDFLAGS=/d' \
+ || die "sed configure"
+ default
+}
+
+src_configure() {
+ # Note this is not an autoconf configure script. econf fails
+ append-flags -DCLK_TCK=CLOCKS_PER_SEC
+ ./configure --prefix=/usr --with-c-compiler=$(tc-getCC) || die "bad configure"
+}
+
+src_install() {
+ dosbin timed/timed/timed
+ doman timed/timed/timed.8
+ dosbin timed/timedc/timedc
+ doman timed/timedc/timedc.8
+ dodoc README ChangeLog BUGS
+
+ newinitd "${FILESDIR}"/timed.rc6 timed
+}