summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-11-29 14:31:21 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-11-29 14:31:33 +0100
commit52119f2eb4ddc5113df09d07274e1919e37ac77a (patch)
treed42654487feaebe92414bf7f9e4ed6996b8d5690 /net-misc/nextcloud-client/files
parentapp-shells/bash-completion: Fix unquoted ~ in readline patch, #601194 (diff)
downloadgentoo-52119f2eb4ddc5113df09d07274e1919e37ac77a.tar.gz
gentoo-52119f2eb4ddc5113df09d07274e1919e37ac77a.tar.bz2
gentoo-52119f2eb4ddc5113df09d07274e1919e37ac77a.zip
net-misc/nextcloud-client: desktop fixes
Fix dolphin integration, thanks Felix Tiede in bug #600116 Fix menu icon, bug #601150 Package-Manager: portage-2.3.2
Diffstat (limited to 'net-misc/nextcloud-client/files')
-rw-r--r--net-misc/nextcloud-client/files/nextcloud-client-2.2.4-dolphin.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-misc/nextcloud-client/files/nextcloud-client-2.2.4-dolphin.patch b/net-misc/nextcloud-client/files/nextcloud-client-2.2.4-dolphin.patch
new file mode 100644
index 000000000000..eea7fad024ac
--- /dev/null
+++ b/net-misc/nextcloud-client/files/nextcloud-client-2.2.4-dolphin.patch
@@ -0,0 +1,28 @@
+--- a/client/shell_integration/dolphin/CMakeLists.txt
++++ b/client/shell_integration/dolphin/CMakeLists.txt
+@@ -49,5 +49,6 @@ target_link_libraries(${OWNCLOUDDOLPHINOVERLAYPLUGIN} KF5::CoreAddons KF5::KIOCo
+ set(OWNCLOUDDOLPHINACTIONPLUGIN ${APPLICATION_EXECUTABLE}dolphinactionplugin)
+ add_library(${OWNCLOUDDOLPHINACTIONPLUGIN} MODULE ownclouddolphinactionplugin.cpp)
+ target_link_libraries(${OWNCLOUDDOLPHINACTIONPLUGIN} KF5::CoreAddons KF5::KIOCore KF5::KIOWidgets ${OWNCLOUDDOLPHINHELPER})
+-install(FILES ownclouddolphinactionplugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} RENAME ${OWNCLOUDDOLPHINACTIONPLUGIN}.desktop)
++configure_file(ownclouddolphinactionplugin.desktop.in ownclouddolphinactionplugin.desktop ESCAPE_QUOTES @ONLY)
++install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ownclouddolphinactionplugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} RENAME ${OWNCLOUDDOLPHINACTIONPLUGIN}.desktop)
+ install(TARGETS ${OWNCLOUDDOLPHINACTIONPLUGIN} DESTINATION ${KDE_INSTALL_PLUGINDIR})
+--- a/client/shell_integration/dolphin/ownclouddolphinactionplugin.desktop
++++ /dev/null
+@@ -1,6 +0,0 @@
+-[Desktop Entry]
+-Type=Service
+-Name=OwncloudAction
+-ServiceTypes=KFileItemAction/Plugin
+-MimeType=application/octet-stream;inode/directory;
+-X-KDE-Library=ownclouddolphinactionplugin
+--- /dev/null
++++ b/client/shell_integration/dolphin/ownclouddolphinactionplugin.desktop.in
+@@ -0,0 +1,6 @@
++[Desktop Entry]
++Type=Service
++Name=@APPLICATION_NAME@Action
++ServiceTypes=KFileItemAction/Plugin
++MimeType=application/octet-stream;inode/directory;
++X-KDE-Library=@APPLICATION_EXECUTABLE@dolphinactionplugin