summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-10 21:11:07 +0000
committerSam James <sam@gentoo.org>2021-06-10 21:11:07 +0000
commit93c801b9f85e64aab83354f3283b5bd89229a044 (patch)
tree62b2c43e340cb3bd27f205d7905a4947636e7078 /net-misc/ntpsec
parentnet-misc/ntpsec: port live to EAPI 7 too (diff)
downloadgentoo-93c801b9f85e64aab83354f3283b5bd89229a044.tar.gz
gentoo-93c801b9f85e64aab83354f3283b5bd89229a044.tar.bz2
gentoo-93c801b9f85e64aab83354f3283b5bd89229a044.zip
net-misc/ntpsec: drop 1.1.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/ntpsec')
-rw-r--r--net-misc/ntpsec/Manifest1
-rw-r--r--net-misc/ntpsec/ntpsec-1.1.9.ebuild160
2 files changed, 0 insertions, 161 deletions
diff --git a/net-misc/ntpsec/Manifest b/net-misc/ntpsec/Manifest
index 7de62087eed7..4f7af2898d26 100644
--- a/net-misc/ntpsec/Manifest
+++ b/net-misc/ntpsec/Manifest
@@ -1,2 +1 @@
-DIST ntpsec-1.1.9.tar.gz 2606066 BLAKE2B bbc482333c7f86936fa20751df1b427bc24be159969050caf5751e26724714bbf6491b120986563497f015c96ac9cdbdf0e999c6446a68798aff23076f631ecc SHA512 e04267aa675a5b528f3478d00329a569ecb9bbe2b6ad18697020854d2ee451bc188c4603cd5f420a08a7e3bf047d2db1301416f57f9156df23aceb1f57303b0b
DIST ntpsec-1.2.0.tar.gz 2625968 BLAKE2B 23ceae5a1f241fcf5a17801fec2f15f9b9d9d64a108bebe29bdc75196303091eaf0efee7df67ce10acefb7c8dba90ce1144a0c0c5432797d7659714d162f26bb SHA512 9e18b3ca2f786a1ea323ba2384b51cff3d862115cea1ae576fc98172c476ac5e7d0d0fc873e47be0b19b050204ea9ed49669d94e66eb94525068dd1b08a8ae71
diff --git a/net-misc/ntpsec/ntpsec-1.1.9.ebuild b/net-misc/ntpsec/ntpsec-1.1.9.ebuild
deleted file mode 100644
index f92de0e4f1d9..000000000000
--- a/net-misc/ntpsec/ntpsec-1.1.9.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE='threads(+)'
-
-inherit flag-o-matic python-r1 waf-utils systemd
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/NTPsec/ntpsec.git"
-else
- SRC_URI="ftp://ftp.ntpsec.org/pub/releases/${PN}-${PV}.tar.gz"
- RESTRICT="mirror"
- KEYWORDS="amd64 arm arm64 ~x86"
-fi
-
-DESCRIPTION="The NTP reference implementation, refactored"
-HOMEPAGE="https://www.ntpsec.org/"
-
-NTPSEC_REFCLOCK=(
- oncore trimble truetime gpsd jjy generic spectracom
- shm pps hpgps zyfer arbiter nmea neoclock modem
- local)
-
-IUSE_NTPSEC_REFCLOCK=${NTPSEC_REFCLOCK[@]/#/rclock_}
-
-LICENSE="HPND MIT BSD-2 BSD CC-BY-SA-4.0"
-SLOT="0"
-IUSE="${IUSE_NTPSEC_REFCLOCK} debug doc early gdb heat libbsd nist ntpviz samba seccomp smear tests" #ionice
-REQUIRED_USE="${PYTHON_REQUIRED_USE} nist? ( rclock_local )"
-
-# net-misc/pps-tools oncore,pps
-CDEPEND="${PYTHON_DEPS}
- sys-libs/libcap
- dev-python/psutil[${PYTHON_USEDEP}]
- libbsd? ( dev-libs/libbsd:0= )
- dev-libs/openssl:0=
- seccomp? ( sys-libs/libseccomp )
-"
-RDEPEND="${CDEPEND}
- ntpviz? ( sci-visualization/gnuplot media-fonts/liberation-fonts )
- !net-misc/ntp
- !net-misc/openntpd
- acct-group/ntp
- acct-user/ntp
-"
-DEPEND="${CDEPEND}
- >=app-text/asciidoc-8.6.8
- dev-libs/libxslt
- app-text/docbook-xsl-stylesheets
- sys-devel/bison
- rclock_oncore? ( net-misc/pps-tools )
- rclock_pps? ( net-misc/pps-tools )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.1.8-fix-missing-scmp_sys-on-aarch64.patch"
- "${FILESDIR}/${P}-remove-asciidoctor-from-config.patch"
-)
-
-WAF_BINARY="${S}/waf"
-
-src_prepare() {
- default
- # Remove autostripping of binaries
- sed -i -e '/Strip binaries/d' wscript || die
- if ! use libbsd ; then
- eapply "${FILESDIR}/${PN}-no-bsd.patch"
- fi
- python_copy_sources
-}
-
-src_configure() {
- is-flagq -flto* && filter-flags -flto* -fuse-linker-plugin
-
- local string_127=""
- local rclocks="";
- local CLOCKSTRING=""
-
- for refclock in ${NTPSEC_REFCLOCK[@]} ; do
- if use rclock_${refclock} ; then
- string_127+="$refclock,"
- fi
- done
- CLOCKSTRING="`echo ${string_127}|sed 's|,$||'`"
-
- local myconf=(
- --nopyc
- --nopyo
- --refclock="${CLOCKSTRING}"
- --build-epoch="$(date +%s)"
- $(use doc || echo "--disable-doc")
- $(use early && echo "--enable-early-droproot")
- $(use gdb && echo "--enable-debug-gdb")
- $(use samba && echo "--enable-mssntp")
- $(use seccomp && echo "--enable-seccomp")
- $(use smear && echo "--enable-leap-smear")
- $(use tests && echo "--alltests")
- $(use debug && echo "--enable-debug")
- )
-
- python_configure() {
- waf-utils_src_configure "${myconf[@]}"
- }
- python_foreach_impl run_in_build_dir python_configure
-}
-
-src_compile() {
- unset MAKEOPTS
- python_compile() {
- waf-utils_src_compile
- }
- python_foreach_impl run_in_build_dir python_compile
-}
-
-src_install() {
- python_install() {
- waf-utils_src_install
- }
- python_foreach_impl run_in_build_dir python_install
- python_foreach_impl python_optimize
-
- # Install heat generating scripts
- use heat && dosbin "${S}"/contrib/ntpheat{,usb}
-
- # Install the openrc files
- newinitd "${FILESDIR}"/ntpd.rc-r2 ntp
- newconfd "${FILESDIR}"/ntpd.confd ntp
-
- # Install the systemd unit file
- systemd_newunit "${FILESDIR}"/ntpd-r1.service ntpd.service
-
- # Prepare a directory for the ntp.drift file
- mkdir -pv "${ED}"/var/lib/ntp
- chown ntp:ntp "${ED}"/var/lib/ntp
- chmod 770 "${ED}"/var/lib/ntp
- keepdir /var/lib/ntp
-
- # Install a log rotate script
- mkdir -pv "${ED}"/etc/logrotate.d
- cp -v "${S}"/etc/logrotate-config.ntpd "${ED}"/etc/logrotate.d/ntpd
-
- # Install the configuration file and sample configuration
- cp -v "${FILESDIR}"/ntp.conf "${ED}"/etc/ntp.conf
- cp -Rv "${S}"/etc/ntp.d/ "${ED}"/etc/
-
- # move doc files to /usr/share/doc/"${P}"
- use doc && mv -v "${ED}"/usr/share/doc/"${PN}" "${ED}"/usr/share/doc/"${P}"/html
-}
-
-pkg_postinst() {
- einfo "If you want to serve time on your local network, then"
- einfo "you should disable all the ref_clocks unless you have"
- einfo "one and can get stable time from it. Feel free to try"
- einfo "it but PPS probably won't work unless you have a UART"
- einfo "GPS that actually provides PPS messages."
-}