summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-01-30 18:21:59 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-01-30 18:21:59 -0500
commit3c804c4e6675764ee4dde27630846ef57aafb2fc (patch)
tree09c1b0ac74354a038cb7669d60565b708c936457 /net-misc/nyx
parentnet-misc/electrum: remove older version (diff)
downloadgentoo-3c804c4e6675764ee4dde27630846ef57aafb2fc.tar.gz
gentoo-3c804c4e6675764ee4dde27630846ef57aafb2fc.tar.bz2
gentoo-3c804c4e6675764ee4dde27630846ef57aafb2fc.zip
net-misc/nyx: version bump to 2.1.0
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-misc/nyx')
-rw-r--r--net-misc/nyx/Manifest1
-rw-r--r--net-misc/nyx/nyx-2.1.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-misc/nyx/Manifest b/net-misc/nyx/Manifest
index b11dd65dd5a4..0a595c7548ca 100644
--- a/net-misc/nyx/Manifest
+++ b/net-misc/nyx/Manifest
@@ -1 +1,2 @@
DIST nyx-2.0.4.tar.gz 4074259 BLAKE2B 92296a319947803195a6ae3991f1991c9ee5dc8293144b31d143995a0b897e89812d4b012c330cb2d9e7ee2d2dbbc0ab0bbeb49135ec7e302aefde2dbe8159de SHA512 bb64b6c38bbfc9837215503a69b4a6b7a11b8a1e230f42c51a405472689a3d46d74dd06b2417c90512b63e9605b33198c5132b660f9eca037016a39c5e4f0ecf
+DIST nyx-2.1.0.tar.gz 6908817 BLAKE2B e67305c0e2a066976cc828235bb364a238af2842251b466cc70bf8ad79138ffb5d6c598cf5900b777caf03ffefd0566e9eccfb65131ca0dc26670d71d8f9a756 SHA512 69a645cc811a1b1fbd9cf0501d8f23f1a52e0e92a0598097bb0c9efb040e1895e1dd431bad93be36db0e85ca7ac32ee5c866d50d2812069a39e5160b44575a37
diff --git a/net-misc/nyx/nyx-2.1.0.ebuild b/net-misc/nyx/nyx-2.1.0.ebuild
new file mode 100644
index 000000000000..32e8fbd725b6
--- /dev/null
+++ b/net-misc/nyx/nyx-2.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Utility to monitor real time Tor status information"
+HOMEPAGE="https://nyx.torproject.org"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.torproject.org/nyx.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ net-libs/stem
+ net-vpn/tor"