summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-04-08 14:13:34 +0100
committerMarek Szuba <marecki@gentoo.org>2024-04-08 14:15:19 +0100
commit968c960aa36b23813987a64de48b760322a47cac (patch)
treea1d53bdb68bd23f36760ae54c650e7f4a9254b80 /net-misc/oidc-agent
parentapp-misc/gramps: add 5.2.2, drop 5.2.1 (diff)
downloadgentoo-968c960aa36b23813987a64de48b760322a47cac.tar.gz
gentoo-968c960aa36b23813987a64de48b760322a47cac.tar.bz2
gentoo-968c960aa36b23813987a64de48b760322a47cac.zip
net-misc/oidc-agent: add 5.1.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-misc/oidc-agent')
-rw-r--r--net-misc/oidc-agent/Manifest1
-rw-r--r--net-misc/oidc-agent/oidc-agent-5.1.0.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-misc/oidc-agent/Manifest b/net-misc/oidc-agent/Manifest
index a1f1b3d20bb2..969d1714e0e4 100644
--- a/net-misc/oidc-agent/Manifest
+++ b/net-misc/oidc-agent/Manifest
@@ -1,2 +1,3 @@
DIST oidc-agent-4.5.2.tar.gz 1766905 BLAKE2B 0558778a5162fbbbe29be9a476838d745abf4825e7274487637f368d521e03f6f165ec82129f37f135a6cf3d3d43bb9349574b88763a508bb683cdc8882230d2 SHA512 04c9ddb258c132781eaa875412f0a8d48d2127e5b78ba262eb0240dac05025db62f5d357e4b5c35a9009960b30d63ce96156c8dcf3b5eac4257c02d37578e676
DIST oidc-agent-5.0.1.tar.gz 1802435 BLAKE2B 75bc66bb2c6cc89293c7ad155d35b7a7adb73ad7f8a5aadeb029b43a095e2a80f0fc4505737a0c53c60e6f601acbcab990ad4b572b659050fe36e5dd2e7c4092 SHA512 caffa9d7733690917472d2d48ca58092ab722c5f049750de37169dc0a76ccbe374ae3fb5e56b8c578465e84a2f40795eaa26018281b4f851f7a7c94571d2a124
+DIST oidc-agent-5.1.0.tar.gz 1803314 BLAKE2B 8ce1de7ec6dffa3155200664a93433db4f4a116325d8ce60ffff885d534b3d2367e40577b6b22987e817d92f0020fea97e2224947b27ba10847bb0c347dcdf3a SHA512 f3ecda4445478ea02e833b0b9ed75a517c1ff91f5b0c2cb258cc3a7eacb62cb75b56697e15fa755d9cf45e7a0293c8bd2f6ab8d998dd8680726c4143b1e011bc
diff --git a/net-misc/oidc-agent/oidc-agent-5.1.0.ebuild b/net-misc/oidc-agent/oidc-agent-5.1.0.ebuild
new file mode 100644
index 000000000000..6517defe32b2
--- /dev/null
+++ b/net-misc/oidc-agent/oidc-agent-5.1.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit tmpfiles xdg-utils
+
+DESCRIPTION="Agent and tools for managing OpenID Connect tokens on the command line"
+HOMEPAGE="https://github.com/indigo-dc/oidc-agent"
+SRC_URI="https://github.com/indigo-dc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+IUSE="test"
+
+DEPEND="app-crypt/libsecret
+ dev-libs/cJSON:=
+ dev-libs/libsodium:=
+ media-gfx/qrencode
+ net-libs/libmicrohttpd:=
+ net-libs/webkit-gtk:4.1=
+ net-misc/curl
+ elibc_musl? ( sys-libs/argp-standalone )"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-libs/check )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.1_install-perms.patch
+ "${FILESDIR}"/${PN}-5.0.1_webkit41.patch
+)
+
+src_prepare() {
+ xdg_environment_reset
+ default
+ sed -i -e 's|^\(\s\+\)@|\1|' Makefile || die "Failed to increase verbosity in Makefile"
+}
+
+oidc_emake() {
+ local mymakeargs=(
+ USE_CJSON_SO=1
+ USE_LIST_SO=0
+ USE_MUSTACHE_SO=0
+ USE_ARGP_SO=$(usex elibc_musl 1 0)
+ )
+
+ emake "${mymakeargs[@]}" $@
+}
+
+src_compile() {
+ oidc_emake -j1 create_obj_dir_structure create_picobj_dir_structure # Bug #880157
+ oidc_emake
+}
+
+src_install() {
+ oidc_emake \
+ PREFIX="${ED}" \
+ BIN_AFTER_INST_PATH="/usr" \
+ INCLUDE_PATH="${ED}"/usr/include \
+ LIB_PATH="${ED}"/usr/$(get_libdir) \
+ install
+
+ # This file is not compatible with Gentoo and in any case, we generally
+ # let the users load such agents themselves.
+ rm -f "${ED}"/etc/X11/Xsession.d/91${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ xdg_desktop_database_update
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog
+ elog "You should use oidc-gen to initially generate your account configuration"
+ elog "before it can be loaded into oidc-agent using oidc-add. For details, please"
+ elog "consult the man page of oidc-gen, or full documentation at"
+ elog " https://indigo-dc.gitbooks.io/oidc-agent/"
+ elog
+ else
+ local old_ver
+ for old_ver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 ${old_ver}) != 5 ]]; then
+ ewarn "${PN} 5 is a major release with quite some usability improvements but unfortunately also some breaking changes."
+ ewarn "Please consult"
+ ewarn " https://indigo-dc.gitbook.io/oidc-agent/oidc-agent5"
+ ewarn "for instructions on how to upgrade your configuration to this version"
+ ewarn
+ ewarn "Furthermore, please restart any running instances of ${PN}"
+ ewarn "to make sure they are compatible with the updated clients."
+ ewarn
+ break
+ fi
+ done
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}