summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/olsrd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/olsrd/files')
-rw-r--r--net-misc/olsrd/files/olsrd26
-rw-r--r--net-misc/olsrd/files/olsrd-0.6.1-build_fix.patch11
-rw-r--r--net-misc/olsrd/files/olsrd-0.6.3-make-gtk.patch22
3 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/olsrd/files/olsrd b/net-misc/olsrd/files/olsrd
new file mode 100644
index 000000000000..5b0a68a8d9ac
--- /dev/null
+++ b/net-misc/olsrd/files/olsrd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /etc/olsrd.conf ]; then
+ eerror "You need a /etc/olsrd.conf file to run olsrd"
+ eerror "There is sample file in /usr/share/doc/olsrd-version/"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting olsrd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/olsrd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping olsrd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/olsrd
+ eend $?
+}
diff --git a/net-misc/olsrd/files/olsrd-0.6.1-build_fix.patch b/net-misc/olsrd/files/olsrd-0.6.1-build_fix.patch
new file mode 100644
index 000000000000..9a8683e9d3e8
--- /dev/null
+++ b/net-misc/olsrd/files/olsrd-0.6.1-build_fix.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -71,8 +71,6 @@
+ switch:
+ $(MAKECMD) -C $(SWITCHDIR)
+
+-# generate it always
+-.PHONY: src/builddata.c
+ src/builddata.c:
+ @$(RM) "$@"
+ @echo "#include \"defs.h\"" >> "$@"
diff --git a/net-misc/olsrd/files/olsrd-0.6.3-make-gtk.patch b/net-misc/olsrd/files/olsrd-0.6.3-make-gtk.patch
new file mode 100644
index 000000000000..12e983daca41
--- /dev/null
+++ b/net-misc/olsrd/files/olsrd-0.6.3-make-gtk.patch
@@ -0,0 +1,22 @@
+--- a/gui/linux-gtk/Makefile
++++ b/gui/linux-gtk/Makefile
+@@ -1,8 +1,8 @@
+ CC ?= gcc
+
+-CFLAGS += -Wall `pkg-config --cflags gtk+-2.0`
++CFLAGS += -Wall $(shell pkg-config --cflags gdk-pixbuf-2.0 glib-2.0 gtk+-2.0)
+ LDFLAGS +=
+-LIBS := `pkg-config --libs gtk+-2.0` -lm
++LIBS := $(shell pkg-config --libs gdk-pixbuf-2.0 glib-2.0 gtk+-2.0) -lm
+
+ OBJS= src/main.o src/interface.o src/callbacks.o src/ipc.o \
+ src/packet.o src/nodes.o src/routes.o
+@@ -10,7 +10,7 @@
+ all: olsrd-gui
+
+ olsrd-gui: $(OBJS)
+- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ clean:
+ rm -f $(OBJS) olsrd-gui