summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-30 18:43:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-30 21:12:13 -0500
commitb54a183dd82914e18bd3ddaae8605e029c4ad14d (patch)
tree41edd0e616280b03be74d6e95c057720ae2678d9 /net-misc/openvswitch
parentmedia-libs/webrtc-audio-processing: x86 stable, bug 587010 (diff)
downloadgentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.gz
gentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.bz2
gentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.zip
openstack p2, newton is done, will add heat later
Diffstat (limited to 'net-misc/openvswitch')
-rw-r--r--net-misc/openvswitch/Manifest1
-rw-r--r--net-misc/openvswitch/openvswitch-2.6.0.ebuild162
2 files changed, 163 insertions, 0 deletions
diff --git a/net-misc/openvswitch/Manifest b/net-misc/openvswitch/Manifest
index 0f042922d5b7..efed71d426e2 100644
--- a/net-misc/openvswitch/Manifest
+++ b/net-misc/openvswitch/Manifest
@@ -2,3 +2,4 @@ DIST openvswitch-1.11.0.tar.gz 2551510 SHA256 007d7d3f2deabe5a3845d1045d23b6b1de
DIST openvswitch-2.0.0.tar.gz 2708774 SHA256 5060e2be69cce01c15f67b481482cb1a0eaa6ef5cbdbed592bac3c3ab2a390f8 SHA512 f6d36663b65d054d179e5a09a478cf45ae9510c8f3aa31bb2013aaee1b146ee21ce986bb8b9f63ac72036f94d0b415f30ab874451b661b855f46b44eaa42537d WHIRLPOOL be6ac428d5d01b751d8d6312e7e028a23160d44da62231cc84c21d42c19c8c5f6b9457c29c26e7b283db91b08a00d8b54368534a621e556c54e15c0682dad4a1
DIST openvswitch-2.1.3.tar.gz 3080126 SHA256 43a2562fe5e8e48e997bfdb04691ffaaaefe73069b5699654538bf2f16ebfb1a SHA512 ede64d37f8bf4a475ab3e4a1e0cd83ae1f29df318f7834b804d9f334710ba43b25b9f562f8c7e91041e24f3121fd03e9e09fc789f398d352a2dceaa0576013dd WHIRLPOOL ddd6c1c733a7a139d58d0492ea8c0efa40065443f763faffd5964e5578acfe9b02ec1dd009c52843759d8a93027eb89412e768ca3e70d9ceeb0d030e791a9b7e
DIST openvswitch-2.5.0.tar.gz 4603077 SHA256 34da54fbad503205b1a66b48ca4312679e1ce5b04763a9fb86050b2b25d66f21 SHA512 32addb6ed8d4b78e6eb5b951de6b2390dacb3a66096ff8de6020e6d42d460e1038eec43c4057707942f8043ebcad848488d09c7aabfa4599d53782a9cc69f089 WHIRLPOOL 3b879ce376268bb65858f4c4b7193c54fc43a9903029f2000cee1a4f8739eae3ed5b2ad67c57de7ecfe3028874831796bd69a1b8a0599d9dad56f1b524302c5d
+DIST openvswitch-2.6.0.tar.gz 5386102 SHA256 c6f86b47b5847e739ca1c5a80059a804cd49e2b98eefef0fdbce1c4d93c7d0f1 SHA512 7bcf02a00b94924e7931642790f40a49b86338baa63405e9454bff20b82d5a53bbc43279c223946f082d050c73ce6caedcb8a1e52979c873262bc9e8ff84b42d WHIRLPOOL d275071d3491167d3672966381403e704580797eb53fb8d8da2de3c08efd614a709d70af256172670271601d8d90a1350f1c2fae0e9236f729b6c278d5038513
diff --git a/net-misc/openvswitch/openvswitch-2.6.0.ebuild b/net-misc/openvswitch/openvswitch-2.6.0.ebuild
new file mode 100644
index 000000000000..b80877a35fb3
--- /dev/null
+++ b/net-misc/openvswitch/openvswitch-2.6.0.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit eutils linux-info linux-mod python-r1 systemd autotools
+
+DESCRIPTION="Production quality, multilayer virtual switch"
+HOMEPAGE="http://openvswitch.org"
+SRC_URI="http://openvswitch.org/releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug modules monitor +ssl"
+
+RDEPEND="
+ || (
+ >=sys-apps/openrc-0.10.5
+ sys-apps/systemd
+ )
+ ssl? ( dev-libs/openssl:= )
+ monitor? (
+ ${PYTHON_DEPS}
+ dev-python/twisted-core
+ dev-python/twisted-conch
+ dev-python/twisted-web
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}] )
+ debug? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
+MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ if use modules ; then
+ CONFIG_CHECK+=" ~!OPENVSWITCH"
+ kernel_is ge 3 10 0 || die "Linux >= 3.10.0 and <= 4.8 required for userspace modules"
+ kernel_is le 4 7 999 || die "Linux >= 3.10.0 and <= 4.8 required for userspace modules"
+ linux-mod_pkg_setup
+ else
+ CONFIG_CHECK+=" ~OPENVSWITCH"
+ linux-info_pkg_setup
+ fi
+ use monitor && python-r1_pkg_setup
+}
+
+src_prepare() {
+ # Never build kernelmodules, doing this manually
+ sed -i \
+ -e '/^SUBDIRS/d' \
+ datapath/Makefile.in || die "sed failed"
+ epatch "${FILESDIR}/xcp-interface-reconfigure-2.3.2.patch"
+ eautoreconf
+ default
+}
+src_configure() {
+ set_arch_to_kernel
+ use monitor || export ovs_cv_python="no"
+ #pyside is staticly disabled
+ export ovs_cv_pyuic4="no"
+
+ local linux_config
+ use modules && linux_config="--with-linux=${KV_OUT_DIR}"
+
+ PYTHON=python2.7 econf ${linux_config} \
+ --with-rundir=/var/run/openvswitch \
+ --with-logdir=/var/log/openvswitch \
+ --with-pkidir=/etc/ssl/openvswitch \
+ --with-dbdir=/var/lib/openvswitch \
+ $(use_enable ssl) \
+ $(use_enable !debug ndebug)
+}
+
+src_compile() {
+ default
+
+# use monitor && python_fix_shebang \
+# utilities/ovs-{pcap,tcpundump,test,vlan-test} \
+# utilities/bugtool/ovs-bugtool
+ if use monitor; then
+ sed -i \
+ 's/^#\!\ python2\.7/#\!\/usr\/bin\/env\ python2\.7/' \
+ utilities/ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpundump,test,vlan-test} \
+ utilities/bugtool/ovs-bugtool || die "sed died :("
+ fi
+
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ default
+
+ if use monitor ; then
+ python_domodule "${ED}"/usr/share/openvswitch/python/*
+ rm -r "${ED}/usr/share/openvswitch/python"
+ python_optimize "${ED}/usr/share/ovsdbmonitor"
+ fi
+ # not working without the brcompat_mod kernel module which did not get
+ # included in the kernel and we can't build it anymore
+ rm "${D}/usr/sbin/ovs-brcompatd" "${D}/usr/share/man/man8/ovs-brcompatd.8"
+
+ keepdir /var/{lib,log}/openvswitch
+ keepdir /etc/ssl/openvswitch
+ fperms 0750 /etc/ssl/openvswitch
+
+ rm -rf "${ED}/var/run"
+ use monitor || rmdir "${ED}/usr/share/ovsdbmonitor"
+ use debug || rm "${ED}/usr/bin/ovs-parse-leaks"
+
+ newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
+ newconfd "${FILESDIR}/ovs-vswitchd_conf" ovs-vswitchd
+ newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
+ newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
+
+ systemd_dounit "${FILESDIR}/ovsdb-server.service"
+ systemd_dounit "${FILESDIR}/ovs-vswitchd.service"
+ systemd_newtmpfilesd "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
+
+ insinto /etc/logrotate.d
+ newins rhel/etc_logrotate.d_openvswitch openvswitch
+
+ use modules && linux-mod_src_install
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ for pv in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 1.9.0 ${pv} ; then
+ ewarn "The configuration database for Open vSwitch got moved in version 1.9.0 from"
+ ewarn " /etc/openvswitch"
+ ewarn "to"
+ ewarn " /var/lib/openvswitch"
+ ewarn "Please copy/move the database manually before running the schema upgrade."
+ ewarn "The PKI files are now supposed to go to /etc/ssl/openvswitch"
+ fi
+ done
+
+ elog "Use the following command to create an initial database for ovsdb-server:"
+ elog " emerge --config =${CATEGORY}/${PF}"
+ elog "(will create a database in /var/lib/openvswitch/conf.db)"
+ elog "or to convert the database to the current schema after upgrading."
+}
+
+pkg_config() {
+ local db="${EPREFIX}/var/lib/openvswitch/conf.db"
+ if [ -e "${db}" ] ; then
+ einfo "Database '${db}' already exists, doing schema migration..."
+ einfo "(if the migration fails, make sure that ovsdb-server is not running)"
+ "${EPREFIX}/usr/bin/ovsdb-tool" convert "${db}" "${EPREFIX}/usr/share/openvswitch/vswitch.ovsschema" || die "converting database failed"
+ else
+ einfo "Creating new database '${db}'..."
+ "${EPREFIX}/usr/bin/ovsdb-tool" create "${db}" "${EPREFIX}/usr/share/openvswitch/vswitch.ovsschema" || die "creating database failed"
+ fi
+}