summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-04 10:18:51 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-04 10:21:14 +0100
commitcc9850529837ef703aedff1a5b59093371645587 (patch)
tree5a5b47508a9e16817850241e433c749840c10cd2 /net-misc/packETH
parentx11-libs/cairo: tweak for binutils-2.34, bug #707960 (diff)
downloadgentoo-cc9850529837ef703aedff1a5b59093371645587.tar.gz
gentoo-cc9850529837ef703aedff1a5b59093371645587.tar.bz2
gentoo-cc9850529837ef703aedff1a5b59093371645587.zip
net-misc/packETH: Set CC for USE=cli
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Bug: https://bugs.gentoo.org/show_bug.cgi?id=708190 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/packETH')
-rw-r--r--net-misc/packETH/packETH-2.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-misc/packETH/packETH-2.1.ebuild b/net-misc/packETH/packETH-2.1.ebuild
index 1bfcc33114eb..75ec8e7348eb 100644
--- a/net-misc/packETH/packETH-2.1.ebuild
+++ b/net-misc/packETH/packETH-2.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools
+inherit autotools toolchain-funcs
DESCRIPTION="Packet generator tool for ethernet"
HOMEPAGE="http://packeth.sourceforge.net/"
@@ -44,7 +44,8 @@ src_configure() {
src_compile() {
use gtk && default
- use cli && emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" -C cli
+ use cli && emake \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" -C cli
}
src_install() {