summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-04-20 10:38:21 +0200
committerJeroen Roovers <jer@gentoo.org>2018-04-20 10:38:36 +0200
commit810fb4324383d537649add53b9cbd5628401ab26 (patch)
treefaec3022b9b8f6f19a5b045d0ee1f32543679d91 /net-misc/pipes
parentnet-misc/pipes: Fix line length in <longdescription />. (diff)
downloadgentoo-810fb4324383d537649add53b9cbd5628401ab26.tar.gz
gentoo-810fb4324383d537649add53b9cbd5628401ab26.tar.bz2
gentoo-810fb4324383d537649add53b9cbd5628401ab26.zip
net-misc/pipes: Fix a couple of compiler/QA warnings.
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'net-misc/pipes')
-rw-r--r--net-misc/pipes/files/pipes-1.16.1-execlp.patch14
-rw-r--r--net-misc/pipes/pipes-1.16.1-r1.ebuild29
2 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/pipes/files/pipes-1.16.1-execlp.patch b/net-misc/pipes/files/pipes-1.16.1-execlp.patch
new file mode 100644
index 000000000000..d7e31cced8c8
--- /dev/null
+++ b/net-misc/pipes/files/pipes-1.16.1-execlp.patch
@@ -0,0 +1,14 @@
+--- a/plis.c
++++ b/plis.c
+@@ -443,9 +443,9 @@
+ if(!strncmp(argv[a], "pcon ", 5)) ChildPconTest(argv[a]);
+
+ if(usesh)
+- execl(SHELL, "sh", "-c", argv[a], NULL);
++ execl(SHELL, "sh", "-c", argv[a], (char *) NULL);
+ else
+- execlp(argv[a], NULL);
++ execlp(argv[a], ";", (char *) NULL);
+ }
+ else
+ {
diff --git a/net-misc/pipes/pipes-1.16.1-r1.ebuild b/net-misc/pipes/pipes-1.16.1-r1.ebuild
new file mode 100644
index 000000000000..7d8cc7dd125f
--- /dev/null
+++ b/net-misc/pipes/pipes-1.16.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Very versatile TCP pipes"
+HOMEPAGE="http://bisqwit.iki.fi/source/pipes.html"
+SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+PATCHES=(
+ "${FILESDIR}"/${P}-execlp.patch
+)
+
+src_compile() {
+ # Prevent the build system from looking for dependencies
+ touch .depend || die
+
+ emake CC=$(tc-getCC) OPTIM="${CFLAGS}" LDFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin plis
+ dosym plis /usr/bin/pcon
+ dodoc ChangeLog Examples README.html
+}