summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/proxyper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/proxyper')
-rw-r--r--net-misc/proxyper/Manifest2
-rw-r--r--net-misc/proxyper/files/proxyper.init20
-rw-r--r--net-misc/proxyper/metadata.xml7
-rw-r--r--net-misc/proxyper/proxyper-341a.ebuild52
-rw-r--r--net-misc/proxyper/proxyper-347a.ebuild54
5 files changed, 135 insertions, 0 deletions
diff --git a/net-misc/proxyper/Manifest b/net-misc/proxyper/Manifest
new file mode 100644
index 000000000000..a9e4dbfbfe69
--- /dev/null
+++ b/net-misc/proxyper/Manifest
@@ -0,0 +1,2 @@
+DIST proxyper341a-linux-x86-uclibc.tar.gz 183522 SHA256 cbfa67d8b46270306e4dedcf2f58a9d8023a09495c9533302c6ac3bf558f600d
+DIST proxyper347a-linux-x86-uclibc.tar.gz 180907 SHA256 a473a87d27c21d67412e3e47233837f308a23635b8050b3a14485523b19b713e SHA512 fb8ea1b3104fa9fa77ec116cec925ee066c6b2454e3378a510be2a1af73814e1f5e6e191818a4fdd50c3aa0a7eb66dd1767bb62f3f4f3757b4249ab30a9e5a79 WHIRLPOOL 9fcbbd49a69adb24264da4e3a38d413e45d47ade920bef3e4fc452bd237da6ab1cce6308709f3435244dca8cc650268c5bc9fd01c96a4e46b85074b75fdd9a15
diff --git a/net-misc/proxyper/files/proxyper.init b/net-misc/proxyper/files/proxyper.init
new file mode 100644
index 000000000000..6dea049631aa
--- /dev/null
+++ b/net-misc/proxyper/files/proxyper.init
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting distributed.net personal proxy"
+ start-stop-daemon --start --quiet --pidfile /opt/proxyper/rc5desproxy.pid --exec /opt/proxyper/proxyper -- -detach
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping distributed.net personal proxy"
+ start-stop-daemon --stop --quiet --pidfile /opt/proxyper/rc5desproxy.pid
+ eend $?
+}
diff --git a/net-misc/proxyper/metadata.xml b/net-misc/proxyper/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/net-misc/proxyper/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/proxyper/proxyper-341a.ebuild b/net-misc/proxyper/proxyper-341a.ebuild
new file mode 100644
index 000000000000..f01d3a4653d1
--- /dev/null
+++ b/net-misc/proxyper/proxyper-341a.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="distributed.net personal proxy"
+HOMEPAGE="http://www.distributed.net"
+SRC_URI="http://http.distributed.net/pub/dcti/${PN}/${PN}${PV}-linux-x86-uclibc.tar.gz"
+LICENSE="distributed.net GPL-2"
+SLOT="0"
+KEYWORDS="-alpha -ppc -sparc x86"
+IUSE=""
+DEPEND=""
+RDEPEND="net-dns/host"
+
+S=${WORKDIR}/${PN}${PV}-linux-x86-uclibc
+
+RESTRICT="mirror"
+
+QA_PRESTRIPPED="opt/proxyper/proxyper"
+
+src_install() {
+ local DESTDIR=/opt/proxyper
+ exeinto ${DESTDIR}
+ doexe proxyper || die
+
+ # don't clobber an already existing ini file!
+ insinto ${DESTDIR}
+ if [ ! -f ${DESTDIR}/proxyper.ini ]
+ then
+ doins proxyper.ini || die
+ else
+ newins ${DESTDIR}/proxyper.ini proxyper.ini || die
+ fi
+
+ dodoc ChangeLog.txt
+ dohtml manual.html
+
+ newinitd "${FILESDIR}"/proxyper.init proxyper
+}
+
+pkg_postinst() {
+ einfo "Don't forget to modify the config file"
+ einfo "located in /opt/proxyper/proxyper.ini"
+ einfo "It's recommend to reading the manual first :-)"
+}
+
+pkg_postrm() {
+ local DESTDIR="/opt/proxyper"
+ if [ -d ${DESTDIR} ]; then
+ einfo "All files have not been removed from ${DESTDIR}"
+ fi
+}
diff --git a/net-misc/proxyper/proxyper-347a.ebuild b/net-misc/proxyper/proxyper-347a.ebuild
new file mode 100644
index 000000000000..9776b112df59
--- /dev/null
+++ b/net-misc/proxyper/proxyper-347a.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="distributed.net personal proxy"
+HOMEPAGE="http://www.distributed.net"
+SRC_URI="http://http.distributed.net/pub/dcti/${PN}/${PN}${PV}-linux-x86-uclibc.tar.gz"
+
+LICENSE="distributed.net GPL-2"
+SLOT="0"
+KEYWORDS="-alpha -ppc -sparc ~x86"
+
+RDEPEND="net-dns/host"
+
+S=${WORKDIR}/${PN}${PV}-linux-x86-uclibc
+
+RESTRICT="mirror"
+
+QA_PRESTRIPPED="opt/proxyper/proxyper"
+
+src_install() {
+ local DESTDIR=/opt/proxyper
+ exeinto ${DESTDIR}
+ doexe proxyper
+
+ # don't clobber an already existing ini file!
+ insinto ${DESTDIR}
+ if [ ! -f ${DESTDIR}/proxyper.ini ]
+ then
+ doins proxyper.ini
+ else
+ newins ${DESTDIR}/proxyper.ini proxyper.ini
+ fi
+
+ dodoc ChangeLog.txt
+ dohtml manual.html
+
+ newinitd "${FILESDIR}"/proxyper.init proxyper
+}
+
+pkg_postinst() {
+ einfo "Don't forget to modify the config file"
+ einfo "located in /opt/proxyper/proxyper.ini"
+ einfo "It's recommend to reading the manual first :-)"
+}
+
+pkg_postrm() {
+ local DESTDIR="/opt/proxyper"
+ if [ -d ${DESTDIR} ]; then
+ einfo "All files have not been removed from ${DESTDIR}"
+ fi
+}