summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-09-25 16:05:35 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2017-09-25 16:14:30 +0200
commitce02115b75a0390171c956176a2deb6132ae0752 (patch)
tree26ae2b9eace59828708a034adfc92c7333074817 /net-misc/pyhoca-gui/pyhoca-gui-0.5.0.7.ebuild
parentnet-misc/pyhoca-cli: 0.5.0.4 bump (diff)
downloadgentoo-ce02115b75a0390171c956176a2deb6132ae0752.tar.gz
gentoo-ce02115b75a0390171c956176a2deb6132ae0752.tar.bz2
gentoo-ce02115b75a0390171c956176a2deb6132ae0752.zip
net-misc/pyhoca-gui: 0.5.0.7 bump
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'net-misc/pyhoca-gui/pyhoca-gui-0.5.0.7.ebuild')
-rw-r--r--net-misc/pyhoca-gui/pyhoca-gui-0.5.0.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.7.ebuild b/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.7.ebuild
new file mode 100644
index 000000000000..6ea82c839c84
--- /dev/null
+++ b/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="X2Go graphical client applet"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/notify-python[${PYTHON_USEDEP}]
+ dev-python/pycups[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.5.0.0[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+}