summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-01-01 21:23:05 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-01-01 21:23:16 +0100
commitb570911a04cb01eaf1abf79e5d92d27a78b32fe9 (patch)
tree2595cd692d58989c8fe5ef1f8575218e9d121504 /net-misc/python-x2go/python-x2go-0.6.1.3.ebuild
parentmedia-plugins/kodi-pvr-nextpvr: 3.3.18 version bump (diff)
downloadgentoo-b570911a04cb01eaf1abf79e5d92d27a78b32fe9.tar.gz
gentoo-b570911a04cb01eaf1abf79e5d92d27a78b32fe9.tar.bz2
gentoo-b570911a04cb01eaf1abf79e5d92d27a78b32fe9.zip
net-misc/python-x2go: 0.6.1.3 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc/python-x2go/python-x2go-0.6.1.3.ebuild')
-rw-r--r--net-misc/python-x2go/python-x2go-0.6.1.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-misc/python-x2go/python-x2go-0.6.1.3.ebuild b/net-misc/python-x2go/python-x2go-0.6.1.3.ebuild
new file mode 100644
index 000000000000..684c1fbf55da
--- /dev/null
+++ b/net-misc/python-x2go/python-x2go-0.6.1.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="X2Go client-side Python API"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# TODO: minimal USE flag in net-misc/nx, we only need nxproxy/nxcomp
+DEPEND="dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ net-misc/nx"
+RDEPEND="${DEPEND}"