summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/qtm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/qtm')
-rw-r--r--net-misc/qtm/Manifest1
-rw-r--r--net-misc/qtm/metadata.xml12
-rw-r--r--net-misc/qtm/qtm-1.3.17.ebuild43
3 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/qtm/Manifest b/net-misc/qtm/Manifest
new file mode 100644
index 000000000000..e777a912beb3
--- /dev/null
+++ b/net-misc/qtm/Manifest
@@ -0,0 +1 @@
+DIST qtm-1.3.17.tar.bz2 185310 SHA256 c5cab3e1386e1f7b49cc6711252b1e311a0872e1888b8bdfebaeecf61b52cc85 SHA512 b01568cec8e1550caf06958f196c1d3558511b6dbb32209ae83c4aa401f55fbeff093431103b52aa7ffba903afebd32906008c0c021565df478c2281010d921a WHIRLPOOL a95f1a37df357360594fb19b603ded8654ed086b4b8b65649fb3f739c4dc96079c7b88e31f8a053d722448574cddc11f32626afc8d4e7f7e7460512cb42ca291
diff --git a/net-misc/qtm/metadata.xml b/net-misc/qtm/metadata.xml
new file mode 100644
index 000000000000..a796a4ea0f0e
--- /dev/null
+++ b/net-misc/qtm/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">catkin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/qtm/qtm-1.3.17.ebuild b/net-misc/qtm/qtm-1.3.17.ebuild
new file mode 100644
index 000000000000..5794a4934822
--- /dev/null
+++ b/net-misc/qtm/qtm-1.3.17.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+CMAKE_IN_SOURCE_BUILD="1"
+inherit cmake-utils
+
+DESCRIPTION="Qt4 blogging client"
+HOMEPAGE="http://qtm.blogistan.co.uk"
+SRC_URI="mirror://sourceforge/catkin/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dbus debug ssl"
+RESTRICT="strip"
+
+RDEPEND="dev-qt/qtgui:4
+ dbus? ( dev-qt/qtdbus:4 )
+ x11-proto/xproto
+ dev-lang/perl
+ virtual/perl-Digest-MD5"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( Changelog README )
+
+src_prepare() {
+ # bug 463810
+ sed -i -e '/Categories/s/Application;//' qtm-desktop.sh || die 'sed on qtm-desktop.sh failed'
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs="-DDONT_USE_PTE=FALSE -DINSTALL_MARKDOWN=TRUE
+ $(cmake-utils_use debug QDEBUG)
+ $(cmake-utils_use ssl)"
+ ! use dbus && mycmakeargs="${mycmakeargs} -DDONT_USE_DBUS=TRUE"
+ cmake-utils_src_configure
+}