summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /net-misc/seafile-client
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-misc/seafile-client')
-rw-r--r--net-misc/seafile-client/seafile-client-6.2.11.ebuild6
-rw-r--r--net-misc/seafile-client/seafile-client-7.0.2.ebuild6
-rw-r--r--net-misc/seafile-client/seafile-client-7.0.4.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/net-misc/seafile-client/seafile-client-6.2.11.ebuild b/net-misc/seafile-client/seafile-client-6.2.11.ebuild
index 311ec1fd77c6..77928c949098 100644
--- a/net-misc/seafile-client/seafile-client-6.2.11.ebuild
+++ b/net-misc/seafile-client/seafile-client-6.2.11.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Seafile desktop client"
HOMEPAGE="https://github.com/haiwen/seafile-client/ http://www.seafile.com/"
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
src_prepare() {
eapply "${FILESDIR}/${PN}-select-qt5.patch"
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -40,7 +40,7 @@ src_configure() {
-DBUILD_SHIBBOLETH_SUPPORT="$(usex shibboleth)"
-DBUILD_TESTING="$(usex test)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {
diff --git a/net-misc/seafile-client/seafile-client-7.0.2.ebuild b/net-misc/seafile-client/seafile-client-7.0.2.ebuild
index 972e54b95f82..fa31e1e217d9 100644
--- a/net-misc/seafile-client/seafile-client-7.0.2.ebuild
+++ b/net-misc/seafile-client/seafile-client-7.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Seafile desktop client"
HOMEPAGE="https://github.com/haiwen/seafile-client/ http://www.seafile.com/"
@@ -33,7 +33,7 @@ BDEPEND="dev-qt/linguist-tools:5"
src_prepare() {
eapply "${FILESDIR}/${PN}-select-qt5.patch"
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -41,7 +41,7 @@ src_configure() {
-DBUILD_SHIBBOLETH_SUPPORT="$(usex shibboleth)"
-DBUILD_TESTING="$(usex test)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {
diff --git a/net-misc/seafile-client/seafile-client-7.0.4.ebuild b/net-misc/seafile-client/seafile-client-7.0.4.ebuild
index 972e54b95f82..fa31e1e217d9 100644
--- a/net-misc/seafile-client/seafile-client-7.0.4.ebuild
+++ b/net-misc/seafile-client/seafile-client-7.0.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Seafile desktop client"
HOMEPAGE="https://github.com/haiwen/seafile-client/ http://www.seafile.com/"
@@ -33,7 +33,7 @@ BDEPEND="dev-qt/linguist-tools:5"
src_prepare() {
eapply "${FILESDIR}/${PN}-select-qt5.patch"
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -41,7 +41,7 @@ src_configure() {
-DBUILD_SHIBBOLETH_SUPPORT="$(usex shibboleth)"
-DBUILD_TESTING="$(usex test)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {