summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-01-29 10:33:17 +0100
committerJeroen Roovers <jer@gentoo.org>2017-01-29 10:34:27 +0100
commita2e998fabab3f46a0e608e8d5c37ecbde9353731 (patch)
treec457afa10256bb58abef52e4da309763825d3a37 /net-misc/socat/socat-1.7.3.2.ebuild
parentsci-libs/clapack: Remove 3.2.1 (r7) (diff)
downloadgentoo-a2e998fabab3f46a0e608e8d5c37ecbde9353731.tar.gz
gentoo-a2e998fabab3f46a0e608e8d5c37ecbde9353731.tar.bz2
gentoo-a2e998fabab3f46a0e608e8d5c37ecbde9353731.zip
net-misc/socat: Version bump by Marek Behun (bug #607478).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc/socat/socat-1.7.3.2.ebuild')
-rw-r--r--net-misc/socat/socat-1.7.3.2.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/socat/socat-1.7.3.2.ebuild b/net-misc/socat/socat-1.7.3.2.ebuild
new file mode 100644
index 000000000000..8c61f2e7c9a8
--- /dev/null
+++ b/net-misc/socat/socat-1.7.3.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="bindist libressl ssl readline ipv6 tcpd"
+
+DEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ readline? ( sys-libs/readline:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test
+ ssl? ( readline? ( bindist ) )"
+
+DOCS=(
+ BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.3.0-filan-build.patch
+)
+
+pkg_setup() {
+ # bug #587740
+ if use readline && use ssl; then
+ elog "You are enabling both readline and openssl USE flags, the licenses"
+ elog "for these packages conflict. You may not be able to legally"
+ elog "redistribute the resulting binary."
+ fi
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ filter-flags '-Wno-error*' #293324
+ tc-export AR
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc doc/*.html doc/*.css
+}