summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/sparkleshare
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/sparkleshare')
-rw-r--r--net-misc/sparkleshare/Manifest1
-rw-r--r--net-misc/sparkleshare/metadata.xml5
-rw-r--r--net-misc/sparkleshare/sparkleshare-1.1.0.ebuild40
3 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/sparkleshare/Manifest b/net-misc/sparkleshare/Manifest
new file mode 100644
index 000000000000..f7a395c13882
--- /dev/null
+++ b/net-misc/sparkleshare/Manifest
@@ -0,0 +1 @@
+DIST sparkleshare-1.1.0.tar.gz 662567 SHA256 766d264d242e0e2af4255fe75e6918f66b0fa874afab4097010f0d8b55902137 SHA512 9ff8f199d3117301c2fbc10084a3a100bec7124f97374a6608c92de02770b0e9c9ffd4c19a18f688a37ca775fedac7d683dd40e8737c6d651afcb5808ac6e29e WHIRLPOOL 570d9eef95616f5cf6ff2dbfdba941a3eb734699812a20ee84fd97fbe7c955111753c4a105e7f351406e5fded3ed06b22bd9855e3b707800a4a14026e51b0fab
diff --git a/net-misc/sparkleshare/metadata.xml b/net-misc/sparkleshare/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-misc/sparkleshare/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>
diff --git a/net-misc/sparkleshare/sparkleshare-1.1.0.ebuild b/net-misc/sparkleshare/sparkleshare-1.1.0.ebuild
new file mode 100644
index 000000000000..58d15ef61435
--- /dev/null
+++ b/net-misc/sparkleshare/sparkleshare-1.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no" # --enable-debug does not do anything
+
+inherit gnome2 mono-env
+
+DESCRIPTION="Git-based collaboration and file sharing tool"
+HOMEPAGE="http://www.sparkleshare.org"
+SRC_URI="https://bitbucket.org/hbons/sparkleshare/downloads/sparkleshare-linux-${PV}-tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE="" # ayatana
+
+COMMON_DEPEND=">=dev-lang/mono-2.8
+ >=dev-dotnet/glib-sharp-2.12.7
+ >=dev-dotnet/gtk-sharp-2.12.10
+ dev-dotnet/notify-sharp
+ dev-dotnet/webkit-sharp
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-vcs/git-1.7.12
+ gnome-base/gvfs
+ net-misc/curl[ssl]
+ net-misc/openssh
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="News.txt legal/Authors.txt README.md"
+ gnome2_src_configure --disable-appindicator
+ # $(use_enable ayatana appindicator)
+ # requires >=appindicator-sharp-0.0.7
+}