summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-05-11 00:41:50 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-05-11 00:41:50 -0500
commit0b09124316096720964fdd0b837a7b59141c29b9 (patch)
tree925351dab55188caa1c8f0ca5dea5756f2ffc978 /net-misc/spice-gtk/spice-gtk-9999.ebuild
parentnet-misc/spice-gtk: Clean up xdg environment, bug #586642 (diff)
downloadgentoo-0b09124316096720964fdd0b837a7b59141c29b9.tar.gz
gentoo-0b09124316096720964fdd0b837a7b59141c29b9.tar.bz2
gentoo-0b09124316096720964fdd0b837a7b59141c29b9.zip
net-misc/spice-gtk: update live ebuild
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-misc/spice-gtk/spice-gtk-9999.ebuild')
-rw-r--r--net-misc/spice-gtk/spice-gtk-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/net-misc/spice-gtk/spice-gtk-9999.ebuild b/net-misc/spice-gtk/spice-gtk-9999.ebuild
index a2535503f366..15990fa7afd2 100644
--- a/net-misc/spice-gtk/spice-gtk-9999.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-9999.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
GCONF_DEBUG="no"
-WANT_AUTOMAKE="1.12"
VALA_MIN_API_VERSION="0.14"
VALA_USE_DEPEND="vapigen"
-inherit autotools eutils vala git-r3 readme.gentoo-r1
+inherit autotools eutils xdg-utils vala readme.gentoo-r1
DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
HOMEPAGE="http://spice-space.org https://cgit.freedesktop.org/spice/spice-gtk/"
@@ -19,6 +18,7 @@ KEYWORDS=""
IUSE="dbus gstaudio gstvideo gtk3 +introspection lz4 mjpeg policykit pulseaudio sasl smartcard static-libs usbredir vala webdav libressl"
REQUIRED_USE="?? ( pulseaudio gstaudio )"
+
# TODO:
# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
# * use external pnp.ids as soon as that means not pulling in gnome-desktop
@@ -73,12 +73,8 @@ DEPEND="${RDEPEND}
vala? ( $(vala_depend) )
"
-# Hard-deps while building from git:
-# dev-lang/vala:0.14
-# dev-lang/perl
-
src_prepare() {
- epatch_user
+ default
eautoreconf
@@ -91,6 +87,9 @@ src_configure() {
# https://bugzilla.gnome.org/show_bug.cgi?id=744135
addpredict /dev
+ # Clean up environment, bug #586642
+ xdg_environment_reset
+
local myconf
if use vala ; then