summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-06 23:55:00 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-06 23:55:00 +0200
commit21797678c5cc7ef415256b2abf9b1930caa216b2 (patch)
tree9a068b037c0786317dc8dbf466ce904a06ebc75e /net-misc/spiped
parentapp-vim/ferret: version bump. (diff)
downloadgentoo-21797678c5cc7ef415256b2abf9b1930caa216b2.tar.gz
gentoo-21797678c5cc7ef415256b2abf9b1930caa216b2.tar.bz2
gentoo-21797678c5cc7ef415256b2abf9b1930caa216b2.zip
net-misc/spiped: version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc/spiped')
-rw-r--r--net-misc/spiped/Manifest1
-rw-r--r--net-misc/spiped/spiped-1.6.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/spiped/Manifest b/net-misc/spiped/Manifest
index cee6d4cfcbc2..21b1c64b687c 100644
--- a/net-misc/spiped/Manifest
+++ b/net-misc/spiped/Manifest
@@ -1 +1,2 @@
DIST spiped-1.5.0.tgz 68813 SHA256 b2f74b34fb62fd37d6e2bfc969a209c039b88847e853a49e91768dec625facd7 SHA512 55e9f18fc82415d28f44af538c6dd8c222798f6ac719a9ad43772357c0f05f281a883cf1189552deeb4b646abe3d060089d66b5f2ba66b5a2a82627dc62513cc WHIRLPOOL be07cfd67a21dfafc37a1d514193c3f45f9f9cb41a3009d50ad564f39fdde1342d2b716baca2b67040b0a75a9b3d469f372c6cc861c3376117d31d7ec4e4b0b3
+DIST spiped-1.6.0.tgz 94431 SHA256 e6f7f8f912172c3ad55638af8346ae7c4ecaa92aed6d3fb60f2bda4359cba1e4 SHA512 9bca8e7da31b86f956a653279f9346d8270a7e28a07d30b4a7104b21fbfbd1a81410e6a7dc0827127331a8f10226d5b8d2ddaacb94c9f76ecc6d15d728ead27a WHIRLPOOL 7fa1b30ba031b8214ae8fa64ac0d7b4586a9551869f76b16cc5b0d9b043abb79a12905802c34d87ef519183e940735cfdf8e8b7d2ed1bab144d013b2aa28aae9
diff --git a/net-misc/spiped/spiped-1.6.0.ebuild b/net-misc/spiped/spiped-1.6.0.ebuild
new file mode 100644
index 000000000000..ed4c445cb511
--- /dev/null
+++ b/net-misc/spiped/spiped-1.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="secure pipe daemon"
+HOMEPAGE="http://www.tarsnap.com/spiped.html"
+SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+MY_PN="${PN/d/}"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+
+# Blocker added due to #548126
+RDEPEND="
+ ${DEPEND}
+ !net-mail/qlogtools"
+
+src_install() {
+ dobin "${MY_PN}/${MY_PN}"
+ dosbin "${PN}/${PN}"
+
+ doman "${MY_PN}/${MY_PN}.1" "${PN}/${PN}.1"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ dodir "etc/${PN}"
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure spiped via its"
+ elog "configuration file located in /etc/conf.d/."
+ elog
+ elog "Please have a look at this file prior to starting up spiped!"
+ elog
+}