summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-12-11 07:39:24 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-12-11 07:39:52 -0500
commit9b4b7e998c48f42ebd294fd5e017f7126de58024 (patch)
treea9f12558a11ec522f3711900d34f2a3b9324cdf7 /net-misc/stunnel
parentdev-cpp/gtkglextmm: fix bug 552686 (diff)
downloadgentoo-9b4b7e998c48f42ebd294fd5e017f7126de58024.tar.gz
gentoo-9b4b7e998c48f42ebd294fd5e017f7126de58024.tar.bz2
gentoo-9b4b7e998c48f42ebd294fd5e017f7126de58024.zip
net-misc/stunnel: version bump to 5.28
Package-Manager: portage-2.2.24
Diffstat (limited to 'net-misc/stunnel')
-rw-r--r--net-misc/stunnel/Manifest1
-rw-r--r--net-misc/stunnel/stunnel-5.28.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/net-misc/stunnel/Manifest b/net-misc/stunnel/Manifest
index 2dbfbc7597ea..95ae9099ac06 100644
--- a/net-misc/stunnel/Manifest
+++ b/net-misc/stunnel/Manifest
@@ -1,3 +1,4 @@
DIST stunnel-5.24.tar.gz 631730 SHA256 ab2e5a1034d422951ddad21b572eb7fa8efb4c4ce04bc86536c6845f3d02b07e SHA512 d9a1ef9cdd3ffafc2a3d1b3383bcf3dfc1a52cdd5a0bcfd64f50addf78a0fd0ce0def6b32ed801f8dfcabbecd64284454b1c90a18435b5d603ecba594d840340 WHIRLPOOL b625adbc9299c04308733bb5ee732350084b603128734214ec3079f58c02b58d08bfc53bf604468cd83cc5dc1bf5d968a4d5139cd98d7b2219303fdd3d6eae64
DIST stunnel-5.26.tar.gz 635710 SHA256 2c90d469011eed8dc94f003013e3c055de6fdb687ef1e71fa004281d7f7c2726 SHA512 8ac0ed96618855e1361cd0956dbd5b89e08ce7808751c0b3d1c3e74b0bbfb567e1da8ac058544a15ab431598e916214b2c8d411b2c9d2456c9c850eb4935854e WHIRLPOOL 5e278f74c09c270e2de8b8c7fecac07dc9c48c6a147d925bf6d1c29eb7058c58adf58ec9ecf04627f00a826d69cf9cc59ccd41b6d74fb69bb254a5ca567e4fb1
DIST stunnel-5.27.tar.gz 636704 SHA256 7474e986710e88a5cc3330b6b1762f9449f01eccf826fa0f97e56d064c05ead3 SHA512 9dc57f6d2bfb8156de3a1cd3d52e0050498503bddcc02a810ebf798c66e6527bc79dd6b02e3eaf5333131772b9cf0f6d044ee4be3564719d496b07fbeeaeeefa WHIRLPOOL 907ff7f9bda3ac83efeceb66c9d8f2ea83a50be81f1b883f2d7843cb5e984aaff1f16867c909a00bcbba52e41357a375ed21d17500c2aae6294106c5a551d939
+DIST stunnel-5.28.tar.gz 637471 SHA256 9a25b87b1ef0c08fa3d796edce07b4408e6a8acece23de2eb7ee9285b78852b5 SHA512 a01b02afbc05aa7256f245b9142fb17990cd2026274da9358a52778dd0272379aec39e5794c0992e11e3f7584b69fee903742bba9e072bb32928d65bd3abe40a WHIRLPOOL 694510174bd0109fa2de5f036f8c928820192b10a1e1fa223d44db2c619ebe1187027874391423da04a81e8f694dacb48cfdaa0315abf643eadf87e75ed167e2
diff --git a/net-misc/stunnel/stunnel-5.28.ebuild b/net-misc/stunnel/stunnel-5.28.ebuild
new file mode 100644
index 000000000000..d75157cf5747
--- /dev/null
+++ b/net-misc/stunnel/stunnel-5.28.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit ssl-cert eutils multilib systemd user
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://www.stunnel.org/index.html"
+SRC_URI="ftp://ftp.stunnel.org/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://www.usenix.org.uk/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://ftp.nluug.nl/pub/networking/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://www.namesdir.com/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://stunnel.cybermirror.org/archive/${PV%%.*}.x/${P}.tar.gz
+ http://mirrors.zerg.biz/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ ftp://mirrors.go-parts.com/stunnel/archive/${PV%%.*}.x/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ipv6 libressl selinux stunnel3 tcpd"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )"
+RDEPEND="${DEPEND}
+ stunnel3? ( dev-lang/perl )
+ selinux? ( sec-policy/selinux-stunnel )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup stunnel
+ enewuser stunnel -1 -1 -1 stunnel
+}
+
+src_prepare() {
+ # Hack away generation of certificate
+ sed -i -e "s/^install-data-local:/do-not-run-this:/" \
+ tools/Makefile.in || die "sed failed"
+
+ echo "CONFIG_PROTECT=\"/etc/stunnel/stunnel.conf\"" > "${T}"/20stunnel
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ $(use_enable ipv6) \
+ $(use_enable tcpd libwrap) \
+ --with-ssl="${EPREFIX}"/usr \
+ --disable-fips
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ rm -f "${ED}"/etc/stunnel/stunnel.conf-sample \
+ "${ED}"/usr/share/man/man8/stunnel.{fr,pl}.8
+ use stunnel3 || rm -f "${ED}"/usr/bin/stunnel3
+
+ # The binary was moved to /usr/bin with 4.21,
+ # symlink for backwards compatibility
+ dosym ../bin/stunnel /usr/sbin/stunnel
+
+ dodoc AUTHORS BUGS CREDITS PORTS README TODO ChangeLog
+ dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html \
+ tools/importCA.html
+
+ insinto /etc/stunnel
+ doins "${FILESDIR}"/stunnel.conf
+ doinitd "${FILESDIR}"/stunnel
+
+ doenvd "${T}"/20stunnel
+
+ systemd_dounit "${S}/tools/stunnel.service"
+ systemd_newtmpfilesd "${FILESDIR}"/stunnel.tmpfiles.conf stunnel.conf
+}
+
+pkg_postinst() {
+ if [ ! -f "${EROOT}"/etc/stunnel/stunnel.key ]; then
+ install_cert /etc/stunnel/stunnel
+ chown stunnel:stunnel "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ chmod 0640 "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ fi
+
+ einfo "If you want to run multiple instances of stunnel, create a new config"
+ einfo "file ending with .conf in /etc/stunnel/. **Make sure** you change "
+ einfo "\'pid= \' with a unique filename."
+}