summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/tcpsound
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/tcpsound')
-rw-r--r--net-misc/tcpsound/Manifest1
-rw-r--r--net-misc/tcpsound/files/tcpsound-0.3.1-makefile.patch52
-rw-r--r--net-misc/tcpsound/files/tcpsound-0.3.1-misc.patch22
-rw-r--r--net-misc/tcpsound/metadata.xml5
-rw-r--r--net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild32
5 files changed, 112 insertions, 0 deletions
diff --git a/net-misc/tcpsound/Manifest b/net-misc/tcpsound/Manifest
new file mode 100644
index 000000000000..78d2535c8814
--- /dev/null
+++ b/net-misc/tcpsound/Manifest
@@ -0,0 +1 @@
+DIST tcpsound-0.3.1.tar.gz 155357 SHA256 358869ee017f9ccb62f8425bbc1ec70b65316b981dbf7a7b6b22042ae32b57c6 SHA512 9db7c03f57f0e95b5b6b947bdeff9664dda6f6039e1080611205ca15648cb9b31325f462b31cbb1462a4aa767a9c89d6125c17144bb0dd7d0acf89e24b2f3055 WHIRLPOOL e8bc4575bfaeeab075967cc797f50eb2e6a09c37d22e22a9ad5c11a3188db56f185d4c94268d5cee042155ea0205a8d86efd41642c7e65cb62e9543719b070da
diff --git a/net-misc/tcpsound/files/tcpsound-0.3.1-makefile.patch b/net-misc/tcpsound/files/tcpsound-0.3.1-makefile.patch
new file mode 100644
index 000000000000..83f694878376
--- /dev/null
+++ b/net-misc/tcpsound/files/tcpsound-0.3.1-makefile.patch
@@ -0,0 +1,52 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,32 +1,35 @@
+ # Makefile for tcpsound
+
+-prefix = /usr/local
++prefix = $(DESTDIR)/usr
+
+ bindir = $(prefix)/bin
+-wavdir = $(prefix)/share/sounds
++wavdir = $(prefix)/share/tcpsound
+ includedir = $(prefix)/include
+ libdir = $(prefix)/lib
+-mandir = $(prefix)/man
++mandir = $(prefix)/share/man/man1
+ MAN = tcpsound.1
+ MANGZ = $(MAN:.1=.1.gz)
+-MKTOOL = ./mktool
+-CFLAGS = -c -v -g -W1 -I$(includedir) -L$(libdir) -lSDL -lmba -lpthread
+-CC = $(MKTOOL)
++MKTOOL = install
++CFLAGS += -I$(includedir)
++LIBS = -lSDL -lmba -lpthread
+
+ .SUFFIXES: .1 .1.gz
+
+-tcpsound: mktool src/tcpsound.c src/sound.h src/sound.c src/parse.h src/parse.c
+- @$(CC) $(CFLAGS) src/sound.c src/parse.c src/tcpsound.c -o tcpsound
+-play: mktool src/play.c
+- @$(CC) $(CFLAGS) src/play.c -o play
++tcpsound: src/tcpsound.c src/sound.h src/sound.c src/parse.h src/parse.c
++ $(CC) $(LDFLAGS) $(CFLAGS) src/sound.c src/parse.c src/tcpsound.c -o tcpsound $(LIBS)
++play: src/play.c
++ $(CC) $(LDFLAGS) $(CFLAGS) src/play.c -o play $(LIBS)
+
+ mktool:
+ cc -g -o mktool mktool.c
+
+-install: mktool
+- $(MKTOOL) -i -m 0755 tcpsound $(bindir)
+- $(MKTOOL) -i wavs/*.wav $(wavdir)
+- -$(MKTOOL) -i docs/man/*.1.gz $(mandir)/man1
++install: tcpsound
++ $(MKTOOL) -d $(bindir)
++ $(MKTOOL) -d $(wavdir)
++ $(MKTOOL) -d $(mandir)
++ $(MKTOOL) -m 0755 tcpsound $(bindir)
++ $(MKTOOL) -m 0644 wavs/*.wav $(wavdir)
++ -$(MKTOOL) -m 0644 docs/man/tcpsound.1.gz $(mandir)
+ @echo
+ @echo installation successful
+ uninstall: mktool
diff --git a/net-misc/tcpsound/files/tcpsound-0.3.1-misc.patch b/net-misc/tcpsound/files/tcpsound-0.3.1-misc.patch
new file mode 100644
index 000000000000..7c7136fb954e
--- /dev/null
+++ b/net-misc/tcpsound/files/tcpsound-0.3.1-misc.patch
@@ -0,0 +1,22 @@
+--- a/src/tcpsound.c
++++ b/src/tcpsound.c
+@@ -16,7 +16,7 @@
+ #include "parse.h"
+ #include "sound.h"
+
+-static const char *DEFAULT_CONF = "searchpath = /usr/share/sounds:/usr/local/share/sounds\n\nsnd.default = 1,0,0,generic.wav\nsnd.icmp = 3,0,0,sonar.wav\nsnd.dns = 2,53,53,warning.wav\nsnd.http.in = 2,0,80,pop.wav\nsnd.http.out = 2,80,0,info.wav\nsnd.win.nam = 2,137,137,cuckoo.wav\n";
++static const char *DEFAULT_CONF = "searchpath = /usr/share/tcpsound\n\nsnd.default = 1,0,0,generic.wav\nsnd.icmp = 3,0,0,sonar.wav\nsnd.dns = 2,53,53,warning.wav\nsnd.http.in = 2,0,80,pop.wav\nsnd.http.out = 2,80,0,info.wav\nsnd.win.nam = 2,137,137,cuckoo.wav\n";
+
+ /* struct packet {
+ * unsigned long time;
+--- a/elaborate.conf
++++ b/elaborate.conf
+@@ -7,7 +7,7 @@
+ # to searchpath).
+ #
+
+-searchpath = /usr/share/sounds:/usr/local/share/sounds
++searchpath = /usr/share/tcpsound
+
+ snd.default = 1,0,0,generic.wav
+ snd.icmp = 3,0,0,sonar.wav
diff --git a/net-misc/tcpsound/metadata.xml b/net-misc/tcpsound/metadata.xml
new file mode 100644
index 000000000000..78692635ad22
--- /dev/null
+++ b/net-misc/tcpsound/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild b/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..ba8ebc99a8eb
--- /dev/null
+++ b/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Play sounds in response to network traffic"
+LICENSE="BSD"
+HOMEPAGE="http://www.ioplex.com/~miallen/tcpsound/"
+SRC_URI="${HOMEPAGE}dl/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ dev-libs/libmba
+ media-libs/libsdl
+ net-analyzer/tcpdump
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.txt elaborate.conf )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-misc.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}