summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-03-27 13:06:30 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-03-27 13:07:16 +0300
commit837c617684b10593c1ea4d117ebf3dd6a84f10b2 (patch)
tree500c626de30ddac019928b3d96a422ed92ab1b8c /net-misc/teamviewer
parentgames-arcade/jazz2-data: Fix dependencies, add app-arch/unzip (diff)
downloadgentoo-837c617684b10593c1ea4d117ebf3dd6a84f10b2.tar.gz
gentoo-837c617684b10593c1ea4d117ebf3dd6a84f10b2.tar.bz2
gentoo-837c617684b10593c1ea4d117ebf3dd6a84f10b2.zip
net-misc/teamviewer: Version bump (v15.4.4445)
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-misc/teamviewer')
-rw-r--r--net-misc/teamviewer/Manifest2
-rw-r--r--net-misc/teamviewer/teamviewer-15.4.4445.ebuild136
2 files changed, 138 insertions, 0 deletions
diff --git a/net-misc/teamviewer/Manifest b/net-misc/teamviewer/Manifest
index a3e17f444bd1..830f974c0ae3 100644
--- a/net-misc/teamviewer/Manifest
+++ b/net-misc/teamviewer/Manifest
@@ -6,3 +6,5 @@ DIST teamviewer_15.2.2756_amd64.tar.xz 12925536 BLAKE2B 94029edb0c333bbab3dc8ed0
DIST teamviewer_15.2.2756_i386.tar.xz 13456056 BLAKE2B cd41db000d5d7fe67f888026146affcfd08495c4e275b1e66ffcc71224b75643713a6f59598eb94aae473d1ec3e9dd500c40e28017bec1f2d50f27f182a01ed7 SHA512 17c0da4599ae1c111ff1ac3069bbb7b613175253a13086c1d564e0ab268317e6249daa3453d686379b3c29cc5cd76a74c2e6654bed8326ee1c8f46e40cbb4888
DIST teamviewer_15.3.2682_amd64.tar.xz 13066268 BLAKE2B 701a1c53486b186ebdeee8c4611aba5a96155345e2aa484c8aa1c917d6ef12297ae45946604ba23332e3ce40ec60ea5f85b272289630dc27782122b7c4bd87f2 SHA512 27ac18336339406d7aec30a8765ca61fad45756580e82cb506b52b9fb6f94aea96c67065750c2573430704247be93dca757526a97a7d9b41ade9c88fb66dd267
DIST teamviewer_15.3.2682_i386.tar.xz 13602852 BLAKE2B 4a3ec9062dd2c670395953bdcc5beb923e37ed00ee315c1a051d10b15e16dfe9fcf00f6b1308180a007257edff931c9a210da4b8520963f2ef0df9406e27b9e8 SHA512 bc599059f5d2b9178db39c1d9cb55303493bd734642bc0aecceb8bbe025056a4a61a50055cfb4ed5841787bdf41a6c544603cde13a724f737677d0710157f077
+DIST teamviewer_15.4.4445_amd64.tar.xz 13056296 BLAKE2B f96bfa24fecec42cd591db8e1e4c471d02fa3de927169e449689507694d162d9b2dd0dce252699c81d18a83a5d58f33f70189cfe824e5388b391ed9b198b4459 SHA512 1fc2ff655f7455d3b11a913ef2342539c5845e0490f26c51e9cb4437185b1d0bd4371c9be3b8c4931ee0f1e97c59bbd06414788af6f8cce80579edf2e11a53b7
+DIST teamviewer_15.4.4445_i386.tar.xz 13631276 BLAKE2B f836e68c96d5b0e05c7033504c4b3624d7ab4eed4e0506535ab23e18d2611a506cdc57128bca1b27db3ecb8d4dcdda917f74deacefdd52a0ffc5626417ce62c6 SHA512 d4181241f2732310e9cb2fb7cfda3b9679b26bd9c11a8934d5c528878cb703611b86d95edb44e928b72ee5c127888aa7e27a466698d1ca5515e2a1077a921d52
diff --git a/net-misc/teamviewer/teamviewer-15.4.4445.ebuild b/net-misc/teamviewer/teamviewer-15.4.4445.ebuild
new file mode 100644
index 000000000000..3441acea1e60
--- /dev/null
+++ b/net-misc/teamviewer/teamviewer-15.4.4445.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN}${PV/\.*}
+inherit desktop gnome2-utils systemd
+
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="https://www.teamviewer.com"
+SRC_URI="amd64? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_amd64.tar.xz )
+ x86? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_i386.tar.xz )"
+
+LICENSE="TeamViewer MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ sys-apps/dbus
+ !sys-auth/consolekit
+"
+
+# For consolekit incompatibility see https://forums.gentoo.org/viewtopic-p-8332956.html?sid=3cc21e5a27935e38975ee85bf03317ae#8332956
+
+RESTRICT="bindist mirror"
+
+# Silence QA messages
+QA_PREBUILT="opt/${MY_PN}/*"
+
+S="${WORKDIR}"/teamviewer
+
+src_prepare() {
+ default
+
+ # Switch operation mode from 'portable' to 'installed'
+ sed -e "s/TAR_NI/TAR_IN/g" -i tv_bin/script/tvw_config || die
+
+ sed -e "/^ExecStart/s/${PN}/${MY_PN}/" \
+ -i tv_bin/script/teamviewerd.service || die
+}
+
+src_install() {
+ local dst="/opt/${MY_PN}" # install destination
+
+ # Quirk:
+ # Remove Intel 80386 32-bit ELF binary 'libdepend' present in all
+ # archives. It will trip the 'emerge @preserved-libs' logic on amd64
+ # when changing the ABI of one of its dependencies. According to the
+ # TeamViewer devs, this binary is an unused remnant of previous Wine-
+ # based builds and will be removed in future releases anyway
+ rm tv_bin/script/libdepend
+
+ insinto ${dst}
+ doins -r tv_bin
+
+ # Set permissions for executables and libraries
+ for exe in $(find tv_bin -type f -executable -or -name '*.so'); do
+ fperms 755 ${dst}/${exe}
+ done
+
+ # No slotting here, binary expects this service path
+ newinitd "${FILESDIR}"/teamviewerd15.init teamviewerd
+ systemd_dounit tv_bin/script/teamviewerd.service
+
+ insinto /usr/share/dbus-1/services
+ doins tv_bin/script/com.teamviewer.TeamViewer.service
+ doins tv_bin/script/com.teamviewer.TeamViewer.Desktop.service
+
+ insinto /usr/share/polkit-1/actions
+ doins tv_bin/script/com.teamviewer.TeamViewer.policy
+
+ for size in 16 24 32 48 256; do
+ newicon -s ${size} tv_bin/desktop/teamviewer_${size}.png TeamViewer.png
+ done
+
+ # Install documents (NOTE: using 'dodoc -r doc' instead of loop will
+ # have the undesired result of installing subdirectory 'doc' in /usr/
+ # share/doc/teamviewer-<version>)
+ for doc in $(find doc -type f); do
+ dodoc ${doc}
+ done
+
+ keepdir /etc/${MY_PN}
+ dosym ../../etc/${MY_PN} ${dst}/config
+
+ # Create directory and symlink for log files (NOTE: according to Team-
+ # Viewer devs, all paths are hard-coded in the binaries; therefore
+ # using the same path as the DEB/RPM archives, i.e. '/var/log/teamviewer
+ # <major-version>')
+ keepdir /var/log/${MY_PN}
+ dosym ../../var/log/${MY_PN} ${dst}/logfiles
+
+ dodir /opt/bin
+ dosym ${dst}/tv_bin/teamviewerd /opt/bin/teamviewerd
+ dosym ${dst}/tv_bin/script/teamviewer /opt/bin/teamviewer
+
+ make_desktop_entry teamviewer "TeamViewer ${SLOT}" TeamViewer
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "Please note that parallel installation of multiple versions of"
+ elog "TeamViewer is currently not supported at runtime. Bug #621818"
+ elog ""
+ elog "Before using TeamViewer, you need to start its daemon:"
+ elog "OpenRC:"
+ elog "# /etc/init.d/teamviewerd start"
+ elog "# rc-update add teamviewerd default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start teamviewerd.service"
+ elog "# systemctl enable teamviewerd.service"
+ elog
+ elog "To display additional command line options simply run:"
+ elog "$ teamviewer help"
+ elog
+ elog "Most likely TeamViewer will work normally only on systems with systemd"
+ elog "or elogind. See this thread for additional info:"
+ elog "https://forums.gentoo.org/viewtopic-p-8332956.html?sid=3cc21e5a27935e38975ee85bf03317ae#8332956"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}