summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-03-02 11:49:00 +0100
committerJeroen Roovers <jer@gentoo.org>2018-03-02 11:49:20 +0100
commit2ee9d26b29e4b530359ed0cd793334f5fd0bab0f (patch)
tree60b5e3fa93fcdb82d50d2e6693c7b1fa7af4f044 /net-misc/tn5250/tn5250-0.17.4-r2.ebuild
parentdev-ruby/rest-client: add ruby24 (diff)
downloadgentoo-2ee9d26b29e4b530359ed0cd793334f5fd0bab0f.tar.gz
gentoo-2ee9d26b29e4b530359ed0cd793334f5fd0bab0f.tar.bz2
gentoo-2ee9d26b29e4b530359ed0cd793334f5fd0bab0f.zip
net-misc/tn5250: Fix building against sys-libs/ncurses[tinfo] (bug #596314).
- Drop USE=X (configure: WARNING: unrecognized options: --with-x) - Drop weird build-time only dependency on x11-libs/libXt - Name patches properly. - Add IUSE=static-libs instead of --disable-static - Add linux/Makefile.am patch instead of sedding Makefile.in - Use ltprune.eclass instead of eutils.eclass Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-misc/tn5250/tn5250-0.17.4-r2.ebuild')
-rw-r--r--net-misc/tn5250/tn5250-0.17.4-r2.ebuild31
1 files changed, 13 insertions, 18 deletions
diff --git a/net-misc/tn5250/tn5250-0.17.4-r2.ebuild b/net-misc/tn5250/tn5250-0.17.4-r2.ebuild
index 3bcbdbd72cb6..f3cfbf0f6174 100644
--- a/net-misc/tn5250/tn5250-0.17.4-r2.ebuild
+++ b/net-misc/tn5250/tn5250-0.17.4-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils
+inherit autotools ltprune
DESCRIPTION="IBM AS/400 telnet client which emulates 5250 terminals/printers"
HOMEPAGE="http://tn5250.sourceforge.net/"
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="X libressl ssl"
+IUSE="libressl ssl static-libs"
RDEPEND="
sys-libs/ncurses:=
@@ -21,32 +21,27 @@ RDEPEND="
)
"
-DEPEND="${RDEPEND}
- X? ( x11-libs/libXt )
+DEPEND="
+ ${RDEPEND}
"
PATCHES=(
- "${FILESDIR}/disable-sslv2-and-sslv3.patch"
- "${FILESDIR}/fix-Wformat-security-warnings.patch"
+ "${FILESDIR}"/${PN}-0.17.4-disable-sslv2-and-sslv3.patch
+ "${FILESDIR}"/${PN}-0.17.4-fix-Wformat-security-warnings.patch
+ "${FILESDIR}"/${PN}-0.17.4-tinfo.patch
+ "${FILESDIR}"/${PN}-0.17.4-whoami.patch
)
src_prepare() {
default
-
- # Next, the Makefile for the terminfo settings tries to remove
- # some files it doesn't have access to. We can just remove those
- # lines.
- sed -i \
- -e "/rm -f \/usr\/.*\/terminfo.*5250/d" linux/Makefile.in \
- || die "sed Makefile.in failed"
+ eautoreconf
}
src_configure() {
econf \
- --disable-static \
- --without-python \
- $(use_with X x) \
- $(use_with ssl)
+ $(use_enable static-libs static) \
+ $(use_with ssl) \
+ --without-python
}
src_install() {