summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-03-28 19:16:00 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-03-28 19:18:11 -0400
commit48e3d30f8fe22b0c7e8d28a0f297b063a228ec02 (patch)
treebda89daf768832215537ae92fb73ef992dec3d86 /net-misc/tor
parentMerge remote-tracking branch 'flacjacket/sympy3.5' (diff)
downloadgentoo-48e3d30f8fe22b0c7e8d28a0f297b063a228ec02.tar.gz
gentoo-48e3d30f8fe22b0c7e8d28a0f297b063a228ec02.tar.bz2
gentoo-48e3d30f8fe22b0c7e8d28a0f297b063a228ec02.zip
net-misc/tor: version bump alpha branch to 0.2.8.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/Manifest1
-rw-r--r--net-misc/tor/tor-0.2.8.2_alpha.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/tor/Manifest b/net-misc/tor/Manifest
index 345b3b53282e..7b1494742d4d 100644
--- a/net-misc/tor/Manifest
+++ b/net-misc/tor/Manifest
@@ -1,3 +1,4 @@
DIST tor-0.2.6.10.tar.gz 3587211 SHA256 0542c0efe43b86619337862fa7eb02c7a74cb23a79d587090628a5f0f1224b8d SHA512 4d1fd794d48ada725af829e1c1f3f3b7d8d04f2d1dd22e4f175ddc49401834f2001f04d78b011cdc7e953fe44972f2859d87078489a08ae126b44f93f6b9a438 WHIRLPOOL ba2685454ecb0dd94c568e05fb14526cd06beea6e9c6f7b27328f85c555392b6f42f35dc7860ae25299a830c7f6643963a9b9719a2557c28a7216019c96caf21
DIST tor-0.2.7.6.tar.gz 4869754 SHA256 493a8679f904503048114aca6467faef56861206bab8283d858f37141d95105d SHA512 9b0dbfabe6cd05189b179da24bfaa73b89ab237775e3b5b0ebc0a22ee98909e9b13e55841a466f04000e0ff876c15f76515ff46abca28d05eeddbdc52f183afc WHIRLPOOL 03adf1d113049ad0b7df11f4d7f2d21f2a4582fcf51046534666b748f8d2dae383fa9e9cc2b44a2388f993d21681801bff33cc2a0a9cb5aaa7cfb9600f62e4ad
DIST tor-0.2.8.1-alpha.tar.gz 5021137 SHA256 6e41c12ce13ad9997b42a15ed2350de86682694bfd9d4c98dae874395bbe3ea3 SHA512 ed6bcb0f64f1b829d5c893d582c390a0e2e5b080932639798a7fce8f0a04bf00d26b81a4a2eafe6695787261dddc755e7f178a05166586a5e459460322c62499 WHIRLPOOL 7c3376f2365bb154bd02cb086c4a51bbc9b94d14ba835bbe6e365f86181cfa26307789996d34fab263f10df7e6e34401c03cb8901def86bf73057b6e12ab7e1c
+DIST tor-0.2.8.2-alpha.tar.gz 5073910 SHA256 4756a04dea76395f5caf89de3cd75f05cc8d43576ef0f966cea9259b16eb1628 SHA512 a9bb1910ca0aa57aa4fa8a4c0a20b33d085ac294ab243ae165fe82102e98af56422d2c6a3eaeddb8fd6b2e1ce92058524748716dd67b75a461ab0c6f2a0cf058 WHIRLPOOL 34815b02317b8543243446adc4c5a547ae34d5785d97b6aba3fc41de8c337215f26670564e808246e4ae0da57f5ed20142d4a465093d91da5cb85740d502a4a7
diff --git a/net-misc/tor/tor-0.2.8.2_alpha.ebuild b/net-misc/tor/tor-0.2.8.2_alpha.ebuild
new file mode 100644
index 000000000000..aeefa9fc3aa7
--- /dev/null
+++ b/net-misc/tor/tor-0.2.8.2_alpha.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic readme.gentoo-r1 systemd versionator user
+
+MY_PV="$(replace_version_separator 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
+ https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE="-bufferevents libressl scrypt seccomp selinux stats systemd tor-hardening transparent-proxy test web"
+
+DEPEND="
+ app-text/asciidoc
+ dev-libs/libevent
+ sys-libs/zlib
+ bufferevents? ( dev-libs/libevent[ssl] )
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+ scrypt? ( app-crypt/libscrypt )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-tor )"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
+ epatch_user
+}
+
+src_configure() {
+ # Upstream isn't sure of all the user provided CFLAGS that
+ # will break tor, but does recommend against -fstrict-aliasing.
+ # We'll filter-flags them here as we encounter them.
+ filter-flags -fstrict-aliasing
+
+ econf \
+ --enable-system-torrc \
+ --enable-asciidoc \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable stats instrument-downloads) \
+ $(use_enable bufferevents) \
+ $(use_enable scrypt libscrypt) \
+ $(use_enable seccomp) \
+ $(use_enable systemd) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable web tor2web-mode) \
+ $(use_enable test unittests) \
+ $(use_enable test coverage)
+}
+
+src_install() {
+ readme.gentoo_create_doc
+
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r7 tor
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_dotmpfilesd "${FILESDIR}/${PN}.conf"
+
+ emake DESTDIR="${D}" install
+
+ keepdir /var/lib/tor
+
+ dodoc -r README ChangeLog ReleaseNotes doc/HACKING
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+}