summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-01-25 10:41:09 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-01-25 10:42:42 -0500
commit6fe43379d8a4ac61316e0c5dbb82819340faa7e9 (patch)
tree1f079416694da6852c4f79f3bd553bed7cfce5ef /net-misc/tor
parentapp-admin/mongo-tools: x86 stable wrt bug #568324 (diff)
downloadgentoo-6fe43379d8a4ac61316e0c5dbb82819340faa7e9.tar.gz
gentoo-6fe43379d8a4ac61316e0c5dbb82819340faa7e9.tar.bz2
gentoo-6fe43379d8a4ac61316e0c5dbb82819340faa7e9.zip
net-misc/tor: version bump to 0.2.9.9
Package-Manager: portage-2.3.3
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/Manifest1
-rw-r--r--net-misc/tor/tor-0.2.9.9.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/net-misc/tor/Manifest b/net-misc/tor/Manifest
index 8e03c90f1330..e9d1a106bb38 100644
--- a/net-misc/tor/Manifest
+++ b/net-misc/tor/Manifest
@@ -1,4 +1,5 @@
DIST tor-0.2.8.12.tar.gz 5331785 SHA256 b35748f2839cf8ce9910b677ea873463495ac88689244c007ed038f6887f4aaf SHA512 b0cfa34914208bbb28f74178a87ece2a320a44606a94c35de715548fc5a3517cd3d9bf27512d9efe2f1c4685620a62ed591927f828e72fe5ac0a1fffa543eb26 WHIRLPOOL 342db1479f7c03ac3569b8b3bd86ca315fa7eb23dbb0e22d6f4490d399175b70cd398fc140eb42609b3c9656083ac99a7b6ce8d1eaa30530b6e4a3c20a1177ce
DIST tor-0.2.8.9.tar.gz 5306773 SHA256 3f5c273bb887be4aff11f4d99b9e2e52d293b81ff4f6302b730161ff16dc5316 SHA512 9a02e4f7901c2abb22f8250077bc078e9b6ae122ee54fbe7ecfb505d449e6e1766f6d9f95d7b794063471cbefe7410fece8524910f83579bff00d6da2a8ea6c1 WHIRLPOOL 6b97ad6405ca5043dbdb0c688f736ba4772ff997540dbc8be72755fdd0a53f8fcf8617920fff204d9bbdbf64bd4a1ca605799df364468732c633f45012212025
DIST tor-0.2.9.8.tar.gz 5522235 SHA256 fbdd33d3384574297b88744622382008d1e0f9ddd300d330746c464b7a7d746a SHA512 6a43a56ebed7b24ccdd2474406f25347819d4efec4916bdb2e725177b34e233632cc17e68c823efa3d0aad4a5bd13e00a5077cdfeb8830a612253a03ab91b622 WHIRLPOOL c8524a2b07c781a94acf280158763aa1e914fa8df0a14f8d7584fc353e856f23f6b03bc2185dbb825828c5becc5519709d02dc305c8b2930f50837bc2b766ae9
+DIST tor-0.2.9.9.tar.gz 5534005 SHA256 33325d2b250fd047ba2ddc5d11c2190c4e2951f4b03ec48ebd8bf0666e990d43 SHA512 cbe7e1f3e503b945f150916b7147cf23d1c32c3660e15aecfe5e2f2baac3a241de665e6ce4e81b81229933eba7f02d4a86e8deeabf2378d40fa83a7036928c9b WHIRLPOOL 9fc83693ea3b0519354a6d1fde83d090b66a9738f67abd7be2f9c3a36e95df92968b6da6c8cecd97ad352c70aac62817a86efae2dd42129934c2e6b38577439c
DIST tor-0.3.0.1-alpha.tar.gz 5704559 SHA256 7013353f0cbd2af8c0144f6167339f6eb252eb35ca9a2db2971310171108b064 SHA512 181cada87ece0f1d6f852948a66fdcff013b8db6e3d39a635ef8050c4e7671ade186925297025888151753e6280f7eea4511f2051a19ddac79834caf8f7ba9ea WHIRLPOOL 4b72d5b62c04247edc9ff35401ce808693c05154ec64ec4cae628418e83153060cf6d0dd46e37655e067947bb0771d48e39cbd289bc2bebd14916c1f08e0d87a
diff --git a/net-misc/tor/tor-0.2.9.9.ebuild b/net-misc/tor/tor-0.2.9.9.ebuild
new file mode 100644
index 000000000000..fd3c26d085aa
--- /dev/null
+++ b/net-misc/tor/tor-0.2.9.9.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit eutils flag-o-matic readme.gentoo-r1 systemd versionator user
+
+MY_PV="$(replace_version_separator 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
+ https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE="libressl scrypt seccomp selinux systemd tor-hardening test web"
+
+DEPEND="
+ app-text/asciidoc
+ dev-libs/libevent[ssl]
+ sys-libs/zlib
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+ scrypt? ( app-crypt/libscrypt )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-tor )"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
+ eapply_user
+}
+
+src_configure() {
+ # Upstream isn't sure of all the user provided CFLAGS that
+ # will break tor, but does recommend against -fstrict-aliasing.
+ # We'll filter-flags them here as we encounter them.
+ filter-flags -fstrict-aliasing
+
+ econf \
+ --enable-system-torrc \
+ --enable-asciidoc \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable scrypt libscrypt) \
+ $(use_enable seccomp) \
+ $(use_enable systemd) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening) \
+ $(use_enable web tor2web-mode) \
+ $(use_enable test unittests) \
+ $(use_enable test coverage)
+}
+
+src_install() {
+ readme.gentoo_create_doc
+
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r8 tor
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_dotmpfilesd "${FILESDIR}/${PN}.conf"
+
+ emake DESTDIR="${D}" install
+
+ keepdir /var/lib/tor
+
+ dodoc -r README ChangeLog ReleaseNotes doc/HACKING
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+}