summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGarri Djavadyan <g.djavadyan@gmail.com>2017-12-23 19:27:31 +0500
committerMichał Górny <mgorny@gentoo.org>2018-03-21 11:28:00 +0100
commit39abda0e971135151278cef6aad8acf83d02b881 (patch)
tree54c4bd422e498a54eabe18b9d5ba3bc0a7bf9130 /net-misc/ubridge/ubridge-0.9.14.ebuild
parentdev-perl/Wx-Perl-ProcessStream: EAPI6 + tests (diff)
downloadgentoo-39abda0e971135151278cef6aad8acf83d02b881.tar.gz
gentoo-39abda0e971135151278cef6aad8acf83d02b881.tar.bz2
gentoo-39abda0e971135151278cef6aad8acf83d02b881.zip
net-misc/ubridge: New package
uBridge is a simple application to create user-land bridges between various technologies. Currently bridging between UDP tunnels, Ethernet and TAP interfaces is supported. Packet capture is also supported. Closes: https://bugs.gentoo.org/642070 Closes: https://github.com/gentoo/gentoo/pull/6611 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-misc/ubridge/ubridge-0.9.14.ebuild')
-rw-r--r--net-misc/ubridge/ubridge-0.9.14.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/ubridge/ubridge-0.9.14.ebuild b/net-misc/ubridge/ubridge-0.9.14.ebuild
new file mode 100644
index 000000000000..48fb218aebb8
--- /dev/null
+++ b/net-misc/ubridge/ubridge-0.9.14.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit fcaps toolchain-funcs user
+
+DESCRIPTION="Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces"
+HOMEPAGE="https://github.com/GNS3/ubridge"
+SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ net-libs/libpcap
+ dev-libs/iniparser:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}"/${P}-respect-flags.patch )
+
+pkg_setup() {
+ enewgroup ubridge
+}
+
+src_configure() {
+ export SYSTEM_INIPARSER=1
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ exeinto /usr/bin
+ exeopts -m 710 -g ubridge
+ doexe ubridge
+ dodoc README.rst
+}
+
+pkg_postinst() {
+ fcaps -g ubridge -m 4710 -M 0710 cap_net_raw,cap_net_admin \
+ "${EROOT}"/usr/bin/ubridge
+
+ ewarn "NOTE: To read packets from the network interfaces with ubridge as"
+ ewarn "normal user you have to add trusted users to the ubridge group."
+}