summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-11-05 14:53:41 -0400
committerMike Gilbert <floppym@gentoo.org>2021-11-05 18:46:11 -0400
commit23632b956c384bb0442cd7d078a9376f1f013f49 (patch)
tree784f122ba1a7b2717d0e538117f92d0031fa7646 /net-misc/wget2
parentsys-apps/shadow: stable 4.9-r3 for hppa, bug #813687 (diff)
downloadgentoo-23632b956c384bb0442cd7d078a9376f1f013f49.tar.gz
gentoo-23632b956c384bb0442cd7d078a9376f1f013f49.tar.bz2
gentoo-23632b956c384bb0442cd7d078a9376f1f013f49.zip
net-misc/wget2: avoid eautoreconf
Instead of patching Makefile.am, stub-out LDCONFIG in configure. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-misc/wget2')
-rw-r--r--net-misc/wget2/wget2-2.0.0.ebuild14
-rw-r--r--net-misc/wget2/wget2-9999.ebuild17
2 files changed, 9 insertions, 22 deletions
diff --git a/net-misc/wget2/wget2-2.0.0.ebuild b/net-misc/wget2/wget2-2.0.0.ebuild
index 2926f4837238..36048689f294 100644
--- a/net-misc/wget2/wget2-2.0.0.ebuild
+++ b/net-misc/wget2/wget2-2.0.0.ebuild
@@ -48,17 +48,6 @@ BDEPEND="
RESTRICT="!test? ( test )"
-PATCHES=(
- # Upstream attempts to be "smart" by calling ldconfig in
- # install-exec-hook
- "${FILESDIR}"/${PN}-1.99.2-remove_ldconfig_call.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
src_configure() {
local myeconfargs=(
--disable-static
@@ -79,6 +68,9 @@ src_configure() {
$(use_with pcre libpcre2)
$(use_with psl libpsl)
$(use_with zlib)
+
+ # Avoid calling ldconfig
+ LDCONFIG=:
)
econf "${myeconfargs[@]}"
}
diff --git a/net-misc/wget2/wget2-9999.ebuild b/net-misc/wget2/wget2-9999.ebuild
index b757baf13439..c35c06da76fa 100644
--- a/net-misc/wget2/wget2-9999.ebuild
+++ b/net-misc/wget2/wget2-9999.ebuild
@@ -3,12 +3,10 @@
EAPI=7
-inherit autotools
-
DESCRIPTION="GNU Wget2 is a file and recursive website downloader"
HOMEPAGE="https://gitlab.com/gnuwget/wget2"
if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
+ inherit autotools git-r3
EGIT_REPO_URI="https://gitlab.com/gnuwget/wget2.git"
else
SRC_URI="mirror://gnu/wget/${P}.tar.gz"
@@ -51,12 +49,6 @@ BDEPEND="
RESTRICT="!test? ( test )"
-PATCHES=(
- # Upstream attempts to be "smart" by calling ldconfig in
- # install-exec-hook
- "${FILESDIR}"/${PN}-1.99.2-remove_ldconfig_call.patch
-)
-
src_unpack() {
if [[ "${PV}" == *9999 ]] ; then
git-r3_src_unpack
@@ -71,6 +63,7 @@ src_unpack() {
}
src_prepare() {
+ default
if [[ "${PV}" == *9999 ]] ; then
local bootstrap_opts=(
--gnulib-srcdir=../gnulib
@@ -82,9 +75,8 @@ src_prepare() {
AUTORECONF="/bin/true" \
LIBTOOLIZE="/bin/true" \
sh ./bootstrap "${bootstrap_opts[@]}" || die
+ eautoreconf
fi
- default
- eautoreconf
}
src_configure() {
@@ -106,6 +98,9 @@ src_configure() {
$(use_with pcre libpcre2)
$(use_with psl libpsl)
$(use_with zlib)
+
+ # Avoid calling ldconfig
+ LDCONFIG=:
)
econf "${myeconfargs[@]}"
}